Gene6 FTP Server v3.0 - Руководство

Глава IV - Администрирование

1 - Обзор

В данном окне следует задать параметры администрирования сервера. Сервер работает на определённом порту и может быть связан с одним или несколькими IP.
Настройки будут применяться к пользователям с правами администратора, желающим изменить общие свойства сервера.

630x461 (11901 bytes)

2 - Настройки

624x436 (7021 bytes)

Разное :

Предоставить всем доступ к localhost : пользователи, подключающиеся с локального узла (localhost), могут управлять сервером без логина и пароля. (Рекомендуется отключить эту опцию, если вы создали учётную запись администратора или если есть совместный доступ к компьютеру, на котором запущен FTP сервер).

3 - Настройки журнала

Вы можете включить ведение журнала, чтобы понять, какие действия производят администраторы.

624x436 (9160 bytes)

Журнал :

Вести журнал : включить, отключить ведение журнала.
Путь к файлу : путь для сохранения журнала.
Синтаксис : определите синтаксис для использования в журнале, можно использовать теги.

Журнал кэширования :

Включить кэш : включить, отключить кэширование : кэш уменьшает нагрузку на жёсткий диск, т.к. запись происходит только тогда, когда кэш заполнен или устарел, актуально для серверов с высоким траффиком (нет причин отключать кэш)
Ограничение по размеру : журнал будет записываться каждые x КБайт (по умолчанию 64КБ).
Ограничение по времени : журнал будет записываться каждые x секунд, вне зависимости от того, заполнен он или нет (по умолчанию 60 с.)..

(На сильно загруженных серверах увеличение Ограничения по размеру и Ограничения по времени уменьшает нгрузку на жёсткий диск, но увеличивает объём используемой памяти)

4 - Привязка IP

Привязка порта Администратора к IP и порту позволяет вам не только изменить порт по умолчанию (8021), но и выбрать, на каком IP сервер будет отвечать.
Это может быть полезно для ограничения возможности управления только локальной сетью или локальным узлом.

624x436 (7709 bytes)

Нажмите Добавить (кнопка +), чтобы добавить новый IP для прослушивания, изменить или редактировать текущие записи.

IP/Маска : IP, который будет использоваться (* означает все IP), - если вы хотите ограничить возможность управления только локальным использованием, введите локальный IP.
Порт : порт для прослушивания, по умолчанию 8021.

5 - Доступ по IP

624x436 (7873 bytes)

Ограничение доступа по IP к администрировнию сервера - полезная вещь.
Если вы уверены, что будете управлять вашим G6FTP Server с одного и того же IP, можно добавить его в список доступа по IP, так чтобы только с вашего IP могло производиться управление сервером (также можно задать маску домена : +*.gene6.net).

﻿

Задание ограничений, таких как доступ по IP, позволяет вам запретить доступ или разрешить доступ только пользователям, которым вы доверяете.
Права могут назначаться как по IP, так и по имени узла.

Например :

+*.gene6.net (единственное правило) позволяет любому пользователю с доменным именем gene6.net подключиться к серверу; всем, кто не соответствует правилу, доступ будет запрещён.

-*.gene6.net (единственное правило) позволяет подсоединяться всем, кроме пользователей домена gene6.net.

Вы также можете использовать символы *,?,[x-y] в масках : [192-193].16?.[0-10].*, *.net?.nerim.fr - это допустимые маски.

Имена, задаваемые в списке доступа по IP, не определяются во время работы. Сервер берёт IP клиента, обращает DNS и сравнивает со списком доступа к IP/домену. Домен dyndns работает только в направлении от Имени к IP, по IP нельзя определить доменное имя dyndns, обычно только доменное имя провайдера, например, 12-20-14-25.yourisp.com.


Глава V - Администратор

1 - Обзор

Настройка учётных записей пользователей с правами администратора определяет учётные записи, доступные из клиента Администратора, которые вы можете использовать для удалённого подключения с целью управления вашим FTP-сервером.

630x461 (10757 bytes)

2 - Мастер

Мастер поможет вам настроить новую учётную запись администратора, подсказав основные настраиваемые опции.

Шаг первый : выбор имени новой учётной записи и её пароля.
Пароль по умолчанию хранится в виде хэша MD5, пароль регистрозависимый; вы можете использовать генератор паролей, чтобы сформировать случайный пароль из 8 символов (букв и чисел), после создания он будет скопирован в буфер обмена (вы можете вставить его как текст при помощи меню мыши или сочетания Ctrl+V).

448x307 (8768 bytes)

Второй шаг : выбор типа учётной записи администратора :

- Супер администратор : имеет все права на всём сервере.
- Администратор : имеет ограниченные права в некоторых доменах; ограничено число учётных записей, которые может создавать администратор.

448x307 (8581 bytes)

Окно, содержащее все настройки, будет показано после нажатия на кнопку Завершить (это можно отключить через Администратор / Сервис / Параметры / Отображать свойства пользователя после создания).

3 - Пользователь с правами администратора

624x436 (7880 bytes)

Активен : Включить или отключить пользователя.
Пароль : установить пароль учётной записи (хранится как хэш MD5).

4 - Доступ по IP

624x436 (7578 bytes)

Чтобы усилить безопасность учётной записи администратора, вы можете ограничить административный доступ к серверу диапазоном IP-адресов или известным доменным именем.

﻿

Задание ограничений, таких как доступ по IP, позволяет вам запретить доступ или разрешить доступ только пользователям, которым вы доверяете.
Права могут назначаться как по IP, так и по имени узла.

Например :

+*.gene6.net (единственное правило) позволяет любому пользователю с доменным именем gene6.net подключиться к серверу; всем, кто не соответствует правилу, доступ будет запрещён.

-*.gene6.net (единственное правило) позволяет подсоединяться всем, кроме пользователей домена gene6.net.

Вы также можете использовать символы *,?,[x-y] в масках : [192-193].16?.[0-10].*, *.net?.nerim.fr - это допустимые маски.

Имена, задаваемые в списке доступа по IP, не определяются во время работы. Сервер берёт IP клиента, обращает DNS и сравнивает со списком доступа к IP/домену. Домен dyndns работает только в направлении от Имени к IP, по IP нельзя определить доменное имя dyndns, обычно только доменное имя провайдера, например, 12-20-14-25.yourisp.com.

5 - Права в домене

Вам может потребоваться предоставить общий доступ только к домену и ограничить возможности; это возможно в G6FTP Server.
(эта панель не появляется, если вы не являетесь супер администратором)

624x436 (8600 bytes)

Права : Супер администратор : может менять всё, не ограничен в правах. Администратор : ограничен определёнными доменами и не увидит настройки Администрирования и FTP Сервера в своём клиенте Администратора.

Администратор

Владелец : выберите, к каким доменам есть административный доступ у данной учётной записи (*=все домены)
Основной каталог : учётные записи, созданные этим администратором, будут ограничены указанным каталогом (чтобы предотвратить общий доступ к целому диску), у администратора нет прав для создания доступа к ftp://, empty://, ramdisk:// в нелокальном каталоге. Например : если вы установите c:\ftproot\ Основным каталогом, то новая учётная запись будет иметь доступ только к c:\ftproot\ и подкаталогам.
Макс. число пользователей : Задайте наибольшее число пользователей, которыми может управлять администратор.
Макс. число групп : Задайте наибольшее число групп, которыми может управлять администратор.


Глава XVI - Документы

1 - Запросы на комментарии (RFC)

RFC-775 : http://www.g6ftpserver.com/files/rfc775.txt
RFC-959 : http://www.g6ftpserver.com/files/rfc959.txt
RFC-2228 : http://www.g6ftpserver.com/files/rfc2228.txt
RFC-2389 : http://www.g6ftpserver.com/files/rfc2389.txt
RFC-2428 : http://www.g6ftpserver.com/files/rfc2428.txt
RFC-2577 : http://www.g6ftpserver.com/files/rfc2577.txt

2 - Команды FTP

Здесь приведён список поддерживаемых программой Gene6 FTP Server команд FTP.

ABOR

Прекратить текущую операцию передачи.

Ответы сервера :

  • 226 ABOR command successful.

ALLO size

Возвращает ответ, если клиент может хранить size байт на сервере.

Ответы сервера :

  • 200 ALLO Ok : %d bytes available.
  • 501 Insufficient disk space : only %d bytes available.
  • 501 Required size parameter bad or missing.

APPE pathname

Возобновить передачу файла с именем pathname.

Ответы сервера:

  • 200 Ready to append file "%s" at offset %d.
  • 501 Bad or missing parameters.
  • 521 Data connection cannot be opened with this PROT setting.
  • 550 No port specified.
  • 550 Cannot APPE. No permission.
  • 550 Cannot APPE. (file not found or busy)

AUTH SSL|TLS-P|TLS|TLS-C [RFC-2228]

Установить SSL-зашифрованную сессию.

Ответы сервера :

  • 234 AUTH command ok; starting SSL connection.
  • 431 AUTH service unavailable.
  • 431 Bad or missing parameters.
  • 534 AUTH command is disabled.

CDUP

Перейти в родительский каталог.

Ответы сервера :

  • 250 CWD command successful. "%s" is current directory.
  • 550 CWD failed. "%s" : no such file or directory.
  • 550 CWD failed. No permission.
  • 550 CWD failed. %s

CLNT clientname

Известить сервер о названии приложения клиента.

Ответы сервера:

  • 200 Noted.

CWD pathname

Изменить каталог на pathname.

Ответы сервера :

  • 250 CWD command successful. "%s" is current directory.
  • 550 CWD failed. "%s" : no such file or directory.
  • 550 CWD failed. No permission.
  • 550 CWD failed. %s

DELE pathname

Удалить файл pathname.

Ответы сервера :

  • 250 File "%s" deleted.
  • 450 File "%s" can't be deleted.
  • 550 "%s": no such file.
  • 550 Cannot DELE. No permission.

EPRT |net-prt|net-addr|tcp-port| [RFC-2428]
(sample : EPRT |1|132.235.1.2|6275|)

Настроить порт для данных.

Ответы сервера :

  • 200 Port command successful.
  • 501 Invalid PORT command.
  • 501 Bad or missing parameters.
  • 504 Command not implemented for the specified argument.
  • 522 Network protocol not supported, use (%s)

EPSV net-prt [RFC-2428]

Настроить порт для данных.

Ответы сервера :

  • 229 Entering Extended Passive Mode (%s)
  • 501 PASV not allowed.
  • 501 PASV exception: "Please try again later.".
  • 522 Network protocol not supported, use (%s)

FEAT [RFC-2389]

Ответ - список команд FEAT.

Ответы сервера :

  • 211-Extensions supported:
    AUTH TLS
    PBSZ
    PROT
    CLNT
    COMPRESSION NONE*;ZLIB;
    MDTM
    MLST type*;size*;created;modify;
    PASV
    REST STREAM
    SIZE
    TVFS
    UTF8
    XCRC "filename" SP EP
    XMD5 "filename" SP EP
    211 End.

HELP

Вывести справку по поддерживаемым командам.

Ответы сервера :

  • 214-Supported Commands : (* unimplemented)
    ABOR FEAT PASS RMD STOU* XMD5
    ACCT* HELP PASV RNFR STRU XMKD
    ALLO LIST PORT RNTO SYST XPWD
    APPE MDTM PWD SITE TYPE XRMD
    CDUP MKD QUIT SIZE USER
    CLNT MODE REIN SMNT* XCRC
    CWD NLST REST STAT XCUP
    DELE NOOP RETR STOR XDEL
    SITE PSWD
    SITE ZONE
    214 End.

LIST [sp pathname]

Вывести перечень файлов каталога.

Ответы сервера :

  • 150 Data connection accepted from %s:%d; transfer starting.
  • 150 Opening data connection for directory list.
  • 550 No port specified.

MDTM [YYYYmmDDhhMMss] pathname

Изменить/получить время изменения файла pathname.

Ответы сервера :

  • 213 %s
  • 501 Bad or missing parameters.
  • 550 "%s" : can''t change date/time. No permission.
  • 550 "%s" : no such file or directory.

MKD pathname

Создать каталог pathname.

Ответы сервера :

  • 257 "%s": directory created.
  • 501 Bad or missing parameters.
  • 550 "%s": file or directory already exists.
  • 550 "%s": can't create directory.
  • 550 "%s": can't create directory. No permission.

MLSD [pathname]

Вывести перечень файлов каталога.

Ответы сервера :

  • 150 Data connection accepted from %s:%d; transfer starting.
  • 150 Opening data connection for directory list.
  • 550 No port specified.

MLST [pathname]

Получить статус текущего файла .

Ответы сервера :

  • (example)
    250-Begin
    type=dir;modify=19990930152225; /
    250 End.
  • 550 Permission denied.

MODE mode

Получить статус текущего файла .

Ответы сервера :

  • 200 Mode %s ok.
  • 501 Bad or missing parameters.
  • 504 Command not implemented for the specified argument.

NLST

Вывести перечень файлов каталога.

Ответы сервера :

  • 150 Data connection accepted from %s:%d; transfer starting.
  • 150 Opening data connection for directory list.
  • 550 No port specified.

NOOP

Команда холостой операции.

Ответы сервера :

  • 200 NOOP command successful.

OPTS [RFC-2389]

Настроить опции команды.

Ответы сервера :

  • 200 %s OPTS %s
  • 501 Unknown option.
  • 501 Invalid %s options.

PASS password

Передать пароль.

Ответы сервера :

  • 230 User %s logged in.
  • 421 Can't login : invalid Home Directory.
  • 421 Not logged in, account expired.
  • 421 Service not available, closing control connection.
  • 421 Too many users logged for this account. Try again later.
  • 421 Not logged in, access denied.
  • 421 No more connection allowed for this IP.
  • 421 Login or Password incorrect.
  • 501 Bad or missing parameters.
  • 503 Login with USER first.

PASV

Команда pasv.

Ответы сервера :

  • 227 Entering Passive Mode (xxx,xxx,xxx,xxx,yyy,zzz).
  • 501 PASV not allowed.
  • 501 PASV exception: "Please try again later.".

PBSZ 0

Установить размер буфера защиты.

Ответы сервера :

  • 200 PBSZ=0
  • 501 Bad or missing parameters.
  • 503 Security data exchange not yet completed.

PORT host-port
(пример : PORT 192,168,0,1,4,0)

Настроить порт для данных.

Ответы сервера :

  • 200 Port command successful.
  • 501 Invalid PORT command.
  • 501 Bad or missing parameters.
  • 504 Command not implemented for the specified argument.

PROT mode

Установить Протокол передачи данных.
Режим может быть следующим : 'C', 'P', 'S', 'E'. Если установлен режим 'P', то передача данных приватна.

Ответы сервера :

  • 200 PROT command successful.
  • 504 Command not implemented for the specified argument.

PWD

Распечатать текущий каталог.

Ответы сервера :

  • 257 "%s" is current directory.

QUIT

Завершить сессию клиента и закрыть соединение.

Ответы сервера :

  • 221 Goodbye.

REIN

Позволить клинету снова войти на сервер. Для простоты : клиент должен отключиться.

Ответы сервера :

  • 502 Disconnect first to re-login.

REST position

Перезапустить следующую операцию передачи с позиции position.

Ответы сервера :

  • 200 Restarting at %d. Send STORE or RETRIEVE.
  • 501 Required byte offset parameter bad or missing.

RETR pathname

Получить файл pathname.

Ответы сервера :

  • 150 Opening data connection for %s (%d bytes).
  • 501 Bad or missing parameters.
  • 521 Data connection cannot be opened with this PROT setting.
  • 550 "%s": No Such File.
  • 550 Cannot retrieve.
  • 550 Cannot RETR. Not enough credit.
  • 550 Cannot RETR. No permission.
  • 550 No port specified.

RMD pathname

Удалить каталог pathname.

Ответы сервера :

  • 200 "%s": directory removed.
  • 501 Bad or missing parameters.
  • 550 "%s": no such directory.
  • 550 "%s": can't remove directory. No permission.
  • 550 "%s": "%s": can't remove directory. %s

RNFR pathname

Начать операцию переименования/перемещения файла/каталога pathname.

Ответы сервера :

  • 350 File exists, ready for destination name.
  • 501 Bad or missing parameters.
  • 550 Cannot RNFR. No permission.
  • 550 "%s": no such file or directory.

RNTO pathname

Переименовать/переместить файл/каталог в pathname.

Ответы сервера :

  • 250 File "%s" renamed to "%s".
  • 501 Bad or missing parameters.
  • 503 Bad sequence of commands.
  • 550 File "%s" can't be renamed.
  • 550 "%s": no such file or directory.

SITE MSG message

Отправить сообщение администратору.

Ответы сервера :

  • 200 Message sent to administrator.

SITE PSWD oldpassword newpassword

Изменить пароль учётной записи.

Ответы сервера :

  • 200 Password change successful.
  • 501 Password not changed. No permission.
  • 501 Password not changed. Syntax : SITE PSWD
  • 501 Password not changed. Old password does not match.

SITE ZONE

Возвращает временной пояс сервера.

Ответы сервера :

  • 200 +-timezone.

SIZE pathname

Отобразить размер pathname.

Ответы сервера :

  • 213 %d.
  • 501 Bad or missing parameters.
  • 550 No such file or directory.
  • 550 Command failed: %s.

SMNT pathname

Данная команда позволяет пользователю смонтировать иную структуру данных файловой системы без изменения логина или информации учётной записи. Параметры передачи подобным образом не изменяются. Аргумент команды - путь (pathname), указывающий на каталог или иную системно-зависимую группу файлов.
Эта команда не поддерживается.

Ответы сервера :

  • 202 SMNT : Command not implemented, superfluous at this site.

STAT pathname

Эта команда приведёт к отправке отчёта о статусе по контрольному подключению в форме ответа.

Ответы сервера :

  • 211-
    FTP Server status for :
    (client ip : client port <-> server ip : server port)
    Files Downloaded: 0
    Downloaded: 0 Bytes
    Files Uploaded: 0
    211 Uploaded: 0 Bytes

STOR pathname

Закачать файл pathname.

Ответы сервера :

  • 150 Opening data connection for %s.
  • 426 Insufficient Disk Quota. Transfer of "%s" Aborted.
  • 501 Bad or missing parameters.
  • 521 Data connection cannot be opened with this PROT setting.
  • 550 Cannot STOR. %s
  • 550 Cannot STOR. No permission.
  • 550 No port specified.

STOU

Эта команда действует как STOR, за исключением того, что результирующий файл будет создан в текущем каталоге под уникальным для этого каталога именем.

Ответы сервера :

  • 502 STOU : Command not yet implemented.

STRU structure

Аргумент команды - единичный код символа Telnet, определяющий структуру файла, описанную в Разделе по Представлению и Хранению Данных.
Следующие коды задаются для структуры:
F - File (no record structure)
R - Record structure
P - Page structure

Структура по умолчанию - File.

Ответы сервера :

  • 200 STRU F ok.
  • 501 Bad or missing parameters.
  • 504 Command not implemented for the specified argument.

SYST

Ответы сервера :

  • 215 UNIX Type: L8

TYPE type

Ответы сервера :

  • 200 Type set to %s.
  • 501 Bad or missing parameters.
  • 504 Command not implemented for the specified argument.

USER username

Ответы сервера :

  • 331 Password required for %s.
  • 421 Too many users connected. Try again later.
  • 501 Bad or missing parameters.
  • 501 Disconnect first to re-login.
  • 501 Please AUTH first.

XCRC "filename" SP EP

Вычисляет контрольную сумму CRC32 файла filename от SP до EP.
SP - Начальная точка в байтах
EP - Конечная точка в байтах

Ответы сервера :

  • 250
  • 501 Bad or missing parameters.
  • 504 Command not implemented for the specified argument.

XCUP [RFC-775]

Перейти в родимтельский каталог.

Ответы сервера :

  • 250 CWD command successful. "%s" is current directory.
  • 550 CWD failed. "%s" : no such file or directory.
  • 550 CWD failed. No permission.
  • 550 CWD failed. %s

XMD5 "filename" SP EP

Вычисляет контрольную сумму MD5 файла filename от SP до EP.
SP - Начальная точка в байтах
EP - Конечная точка в байтах

Ответы сервера :

  • 250
  • 501 Bad or missing parameters.
  • 504 Command not implemented for the specified argument.

XMKD pathname [RFC-775]

Создать каталог pathname.

Ответы сервера :

  • 257 "%s": directory created.
  • 501 Bad or missing parameters.
  • 550 "%s": file or directory already exists.
  • 550 "%s": can't create directory.
  • 550 "%s": can't create directory. No permission.

XPWD [RFC-775]

Распечатать текущий рабочий каталог

Ответы сервера :

  • 257 "%s" is current directory.

XRMD pathname [RFC-775]

Удалить каталог pathname.

Ответы сервера :

  • 200 "%s": directory removed.
  • 501 Bad or missing parameters.
  • 550 "%s": no such directory.
  • 550 "%s": can't remove directory. No permission.
  • 550 "%s": "%s": can't remove directory. %s

3 - Часто встречающиеся проблемы

См. Часто задаваемые вопросы (FAQ) : http://www.G6FTPServer.com/?page=faq


Глава IX - Информация домена

1 - Обзор

Информация домена содержит отчёты об активности на вашем сервере, вы также можете проверить, кто в данный момент подключён и что он делает, это также то место, где можно поставить/снять временную блокировку, а также просмотреть трафик домена.

2 - Активность

На этой странице отображается список подключённых в настоящий момент пользователей и их активность в вашем домене.
Информация, включённая в отчёт : ID, Пользователь, IP, Текущий каталог, Последняя команда, Подключён с, Скорость.

Контекстное меню по правой клавише мыши позволяет вам скопировать IP / Имя узла в буфер обмена, отобразить или скрыть ожидающих/закачивающих/загружающих клиентов, сгруппировать по IP/последней команде/имени пользователя.

Следующие настройки улучшают читаемость информации об активности сервера :
- группировать по IP : вы сможете увидеть, кто подсоединён несколько раз или использует загрузку в несколько потоков.
- группировать по последней команде : вы сможете увидеть, какой файл загружают больше всего.
- группировать по имени пользователя : вы сможете просмотреть подключения и активность по учётным записям.

3 - Журнал

Журнал домена содержит команды пользователя и ответы ftp-сервера для вашего домена.
Журналы можно создавать на уровне домена / Журналы и отчёты, см. : Домены

4 - Временный запрет (бан)

Список текущих заблокированных IP.

Нажмите правую клавишу и выберите Добавить, чтобы установить новый запрет.

388x248 (7042 bytes)

После истечения времени блокировки, запрет будет отменён.

5 - Передачи

634x452 (17649 bytes)

Данный график отображает объём передач (трафик) вашего домена за последние 5 минут, последний час или последние сутки.
Настройки осуществляются на уровне домена / Журналы и отчёты, см. : Домены

Вы можете увеличивать части графика при помощи мыши и сохранять график в файл, нажав правую клавишу и выбрав "Сохранить как..." .


Глава VIII - Домены

1 - Обзор

Домены - это хранилище ваших учётных записей.

Настройка домена является важнейшим этапом, т.к. запуск домена означает появление нового сервера в ожидании пользователей.

Именно в настройках домена задаются параметры IP и SSL.

630x461 (19966 bytes)

Выбор любой основной категории (Домен, Настроить, Безопасность) приведет к отображению страницы с описанием подкатегорий.

2 - Мастер

Мастер поможет вам настроить новый Домен, подсказав основные опции, которые необходимо установить.

Шаг первый : выберите имя домена, абсолютные пределы числа клиентов и наибольшее количество соединений с одного IP

425x342 (9103 bytes)

Шаг второй : выберите IP, который будет использоваться доменом (по умолчанию *, для всех IP), укажите номер порта (по умолчанию 21), решите, нужно ли вам SSL-шифрование (явное/неявное).

425x342 (8627 bytes)

Шаг третий : если вы задействовали SSL, следует выбрать или создать сертификат.

425x342 (8175 bytes)

Шаг четвёртый : выберите, какие журналы необходимо вести (по умолчанию, передачи, полоса пропускания).

425x342 (8900 bytes)

Последний шаг : если вы хотите создать анонимную учётную запись домена, установите соответствующий флажок и выберите домашний каталог.

425x342 (7653 bytes)

Окно, содержащее все настройки, будет показано после нажатия на кнопку Завершить (это можно отключить через Администратор / Сервис / Параметры / Отображать свойства домена после создания).

3 - Настройки

630x461 (16723 bytes)

Статус домена : в сети, автономная работа, закрыт (на обслуживание).
Макс. клиентов : Наибольшее число одновременно подключённых пользователей.
Макс.соединений с одного IP : Наибольшее число одновременно подключённых пользователей с одного IP-адреса.

4 - Аутентификация

Здесь представлены настройки Аутентификации.

624x436 (13648 bytes)

Аутентификация по умолчанию предусматривает использование заданного администратором пароля учётной записи пользователя. Используйте эту опцию, если не очень хорошо понимаете дополнительные настройки (или просто полагаете, что вам не нужна расширенная аутентификация), в таком случае, не меняйте настройки на этой странице.

Список методов аутентификации : разрешить/изменить новый метод аутентификации (см. ниже).

Отключить аутентификацию по умолчанию : если заданы дополнительные методы аутентификации, вы можете запретить использовать встроенную аутентификацию (проверка пароля учётной записи пользователя).
Макс.число попыток входа : Ограничить число последовательностей USER/PASS.
Задержка при ошибке входа : установить задержку после команды PASS, если аутентификация неудачна (направлено против методики перебора паролей).
Перенаправить неверный логин : если аутентификация неудачна, произойдёт перенаправление на другую учётную запись.

Расширенная аутентификация :

Встроенная аутентификация G6FTP Server, несмотря на простоту и удобство использования, может показаться недостаточной в некоторых случаях, таких как, например, сайты, управляемые базами данных.
Чтобы заполнить этот пробел, вкладка настроек аутентификации позволяет настроить альтернативные (дополнительные) методы входа на доменном уровне.

Чтобы задать новый метод аутентификации, щёлкните на кнопке "+", появится новое окно с настройками.

481x324 (9841 bytes)

Имя : название метода.
Префикс : префикс будет использоваться для поиска соответствующих учётных записей среди учётных записей сервера в случае, если логин/пароль совпадают с методом аутентификации.
Метод : База данных пользователей NT, База данных ODBC ...

1) База данных пользователей NT :

Домен : задайте домен NT, содержащий учётную запись пользователя windows (пустое поле означает локальный домен).

В случае успешной аутентификации по базе данных пользователей NT, соответствующая учётная запись сервера будет построена следующим образом : Префикс учётной записи + Тип учётной записи NT (например : "NT_" + "guest").
Существует три типа возвращаемых значений для учётных записей NT : "admin", "user", "guest".

Приведём пример с заданным правилом типа Имя = "NT", Префикс = "NT_", Метод = "База данных пользователей NT" :

- Пользователь предоставляет логин = "Charly", пароль = "1a2b3c"
- Аутентификация NT возвращает значение "NT_admin" программе G6FTP Server, если "Charly" - Администратор, "NT_user" - если он обычный пользователь, "NT_guest" - гость.
- Если аутентификация NT завершается неудачно, будет испробован следующий метод аутентификации (и так далее, пока не останется правил; затем будет испробована встроенная аутентификация сервера, если не установлен флажок "Отключить аутентификацию").

В случае успешной аутентификации NT, соответствующая учётная запись G6FTP Server будет называться "NT_user", поэтому её следуте настроить.
(видно, что следует создать всего 3 учётные записи, из-за свойств расширенной аутентификации не все свойства учётной записи пользователя будут применены, т.к. их нельзя хранить для каждого пользователя).

Мы предлагает настроить основную учётную запись с правами доступа, основанными на имени учётной записи (в нашем случае это примерно равно '/', соответствующему 'c:\ftp\$DOM_NAME\$USR_ACCOUNT\').

2) База данных ODBC :

Использование базы данных ODBC позволяет вам облечь управление паролями в конкретную внешнюю форму. Типичный пример - сайт, управляющийся базой данных, с динамически создаваемыми учётными записями, которые разрешают/запрещают доступ по подписке.

Связывающая строка : Связывающая строка ODBC необходима для доступа к базе данных (пример приведён в выпадающем списке).
Запрос : SQL-запрос, который вернёт имя учётной записи (например : 'SELECT password, account FROM ftp_auth WHERE uid=%s' , где 'password' - это предложенный пароль, '%s' - предложенный логин, который будет заменён при выполнении запроса).

Как и при аутентификации NT, будет возвращено название учётной записи.

Приведём пример с заданным правилом типа имя = "DB", Префикс = "DB_", Метод = "База данных ODBC", база данных содержит таблицу следующего вида : id = "1", uid = "Charly", password = "1a2b3c", account = "Charly"

- Пользователь предоставляет логин = "Charly", пароль = "1a2b3c"
- Аутентификация БД вернёт "DB_Charly" программе G6FTP Server.
- Если аутентификация БД завершается неудачно, будет испробован следующий метод аутентификации (и так далее, пока не останется правил; затем будет испробована встроенная аутентификация сервера, если не установлен флажок "Отключить аутентификацию").

Charly войдёт в систему под учётной записью "DB_Charly".

3) Другое : зарезервировано для использования в будущем.

5 - Разное

624x436 (12773 bytes)

Защита от повторных соединений (Anti-Hammering) :

Включено : включить/отключить защиту от повторных соединений.
Сброс при входе : успешный вход на сервер сбрасывает счётчик подключений.
Блокировать IP xx мин., если xx попыток за xx секунд : счётчик будет отслеживать подключения и считать их; если число подключений в период будет превышено, IP пользователя будет заблокирован.

Файлы :

Удалять файлы в Корзину : файлы удаляются в Корзину, при необходимости они могут быть восстановлены (убедитесь, что Корзина достаточно велика - в настройках Windows).
Разрешить удалять файлы с атрибутом "только чтение" : могут быть удалены файлы с атрибутом "только чтение" (если есть право доступа на удаление).

6 - Журналы и отчёты

Журналы - это ключевой пункт ваших сервера и доменов, они будут информировать вас, что происходит на вашем FTP сервере.

Вот доступные настройки :

624x436 (13668 bytes)

Вести журнал : включить, отключить ведение журнала.
Ограничить размер : файл журнала будет перезаписан, если он достигнет заданного размера (переименование по принципу .0, .1, .2 ...)

Кэш включён : включить, отключить кэш : кэш уменьшает нагрузку на жёсткий диск, т.к. запись происходит только тогда, когда кэш заполнен или устарел, актуально для серверов с высоким траффиком.
Ограничить размер : журнал будет записываться каждые x КБайт (по умолчанию 64КБ).
Ограничить время : журнал будет записываться каждые x секунд, вне зависимости от того, заполнен он или нет (по умолчанию 60 с.).

(На сильно загруженных серверах увеличение Ограничения по размеру и Ограничения по времени уменьшает нгрузку на жёсткий диск, но увеличивает объём используемой памяти)

Настройка :

Имя : название вашего журнала.
Тип журнала : тип создаваемого журнала (обычный, передачи, другой)

1) Обычный журнал

Стандартный журнал, содержащий команды и ответы клиента и сервера.

Метод : позволяет чередовать файлы журнала (единый файл, ежедневно, еженедельно, ежемесячно, ежегодно)
Путь к файлу : расположение файла журнала, в пути можно использовать теги, например :$DOM_NAME.log
Записывать в файл : выберите, что писать в файл : выборочно, всё, ничего, только команды клиент/сервер, только комментарии.
Записывать в файл, задать : детальное определение параметров, записываемых в журнал.
Выводить на экран : то же, что и "Записывать в файл", но для вывода на экран клиента Администратора.
Выводить на экран, задать : то же, что и "Записывать в файл, задать", но для вывода на экран клиента Администратора.

2) Передачи

Журнал, содержащий только информацию о передачах файлов, загрузках/закачках.

Журнал : что писать в журнал : загрузки, закачки, то и другое

Метод : позволяет чередовать файлы журнала (единый файл, ежедневно, еженедельно, ежемесячно, ежегодно)
Путь к файлу : расположение файла журнала, в пути можно использовать теги, например :$DOM_NAME-transfers.log

3) Полоса пропускания

Отобразить использование полосы пропускания за последние 5 минут : график будет содержать данные о загрузках, закачках, минимальном, максимальном, среднем значениях за последние 5 минут.
Отобразить использование полосы пропускания за последний час : график будет содержать данные о загрузках, закачках, минимальном, максимальном, среднем значениях, пиковых параметрах за последний час.
Отобразить использование полосы пропускания за последние сутки : график будет содержать данные о загрузках, закачках, минимальном, максимальном, среднем значениях, пиковых параметрах за последние сутки.

4) W3C

Записывать в файл : выберите, чтобы запись шла в файл.
Выводить на экран : то же, что и "Записывать в файл", но для вывода на экран клиента Администратора.

Метод : позволяет чередовать файлы журнала (единый файл, ежедневно, еженедельно, ежемесячно, ежегодно)
Путь к файлу : расположение файла журнала, в пути можно использовать теги, например :$DOM_NAME.log

5) Другое : зарезервировано для использования в будущем.

Вы можете создать несколько различных журналов, чтобы лучше осветить информацию с целью архивного хранения в G6FTP Server. Журналы и отчёты могут быть просмотрены после создания в Домены / yourdomain.com / Журналы и отчёты.

244x194 (4929 bytes)

Пример

Рассмотрим настройку основного журнала вашего домена.

- откройте Свойства домена
- выберите "Журналы и отчёты"
- нажмите Добавить (кнопка +)
- введите новое имя, скажем, "default"
- Выберите тип "Обычный"
- В качестве метода выберите "Журнал меняется еженедельно" (мы хотим, чтобы сервер обновлялся еженедельно)
- оставьте значение пути по умолчанию (журналы будут записываться в подкаталог /logs в установочном каталоге сервера)
- оставьте "Всё" в строках "В файл" и "На экран".

Voila, вы создали журнал по умолчанию, в который будет писаться всё и который будет меняться каждую неделю. Нажмите "Ok".

В окне "Журналы и отчёты" установите флажок "Вести журнал", чтобы начать журналирование, если вы хотите, чтобы файл журнала менялся по достижении заданного размера, например, 5 МБ, введите "5" в строке "Ограничить размер".
(будут последовательно созданы файлы с именами logfile.0, logfile.1 ... в дополнение к еженедельно изменяемым именам)

7 - Сообщения

Если вы полагаете, что встроенные сообщения слишком сложны для пользователей, или хотите перевести их, вы можете определить свои собственные значения.

Эта страничка позволит вам настроить новые сообщения :

624x436 (15018 bytes)

  • Change directory
  • Domain closed
  • File retrieved
  • File stored
  • List
  • Logged in
  • System
  • User quit
  • Welcome message

Сообщение по умолчанию отображается внизу во время правки. Вы также можете использовать теги в сообщении.
(Примечание : не нужно задавать код ошибки, сервер сам отформатирует сообщение перед отправкой его клиенту).

8 - Заблокированные файлы

﻿ Заблокированные файлы - это файлы, которые не могут храниться на сервере.
Вы можете задать маску файлов/пути (поддерживаются ?, *) : *.jpg, c:\path\images_200?\

Примечания :
- правила не применяются к загрузкам, только к закачке на сервер
- правила также применяются при переименовании файла

624x435 (11235 bytes)

9 - Псевдонимы пользователя

Псевдонимы пользователя позволяют вам назначать различные имена (=логины) для одной учётной записи.
Это может быть полезно для анонимной учётной записи, которая иногда называется "ftp" или "guest", в таком случае, вам всего лишь нужно добавить 2 псевдонима (guest, ftp) к анонимной учётной записи.

624x436 (12052 bytes)

10 - Скорость передачи

624x436 (13218 bytes)

Разное :

Не ограничивать скорость для локальных IP-адресов : Не ограничивать скорость для клиентов из локальной сети.

Наибольшая скорость :

Загрузка : сервер не будет передавать файлы быстрее, чем указано здесь.
Закачка : сервер не будет принимать файлы быстрее, чем указано здесь.

11 - Предел передачи

624x436 (12219 bytes)

﻿ Текущее значение : всего МБайт передано.
Макс : максимумальное число МБайт, которое может быть передано.

Сброс (ежедневно, еженедельно, ежемесячно) : ограничения будут сбрасываться каждый выбранный период.

При помощи данной опции вы в качестве хостинговой компании можете назначить максимум трафика в месяц пользователю.

12 - Статистика

624x436 (12999 bytes)

﻿ Подключения : число соединений.

Логины : количество пользователей, вошедших с данным логином.
Неудачные попытки входа : число неудачных подключений.

В данный момент подключено : число пользователей, подключённых к серверу в настоящее время.

Последнее подключение : дата последнего подключения.
Последнее имя пользователя : последний использованный логин (для псевдонимов).
Последний IP : последний известный IP.

Неудачных/прерванных закачек : число неудачных закачек.
Файлов закачано на сервер : число закачанных файлов.
Закачано : количество закачанной информации (байт).

Неудачных/прерванных загрузок : число неудачных загрузок.
Файлов загружено : число загруженных файлов.
Загружено : количество загруженной информации (байт).

Вы можете скопировать текущую статистику в буфер обмена или сбросить её при помощи кнопок панели инструментов.

13 - События

Настройки событий полезны для действий при наступлении события на сервере.

624x436 (11874 bytes)

OnClientBanned : клиенту заблокирован доступ на сервер.
OnClientConnected : подключился новый клиент.
OnClientDisconnected : клиент отключился.
OnClientHammering : клиент сильно превышает число соединений (соединяется снова и снова).
OnClientLoggedIn : клиент успешно вошёл на сервер.
OnClientTimeOut : соедиенние клиента прервано по таймауту.
OnDomainClosed : домен отключён.
OnDomainOpened : домен активен.
OnDomainStarted : создан домен.
OnDomainStopped : удалён домен.
OnDirCreated : создан новый каталог.
OnDirDeleted : удалён каталог.
OnEveryDay : срабатывает каждый день (в полночь).
OnEveryHour : срабатывает каждый час.
OnFileBanned : попытка закачать заблокированный файл.
OnFileDeleted : файл удалён.
OnFileDownloaded : файл загружен.
OnFileRenamed : файл переименован.
OnFileUploaded : файл закачан.
OnFileUploadFailed : закачка файла завершилась неуспешно.
OnIPChanged : (один из) IP сервера поменялся.
OnLogFileRotated : сменился файл журнала.
OnQuotaExceeded : квота учётной записи превышена.
OnSameIPConnect : попытка соединения с IP, который уже подключён к серверу.
OnTooManyClient : подключено слишком много клиентов.

Например, скажем, вы хотите переместить все закачанные файлы в другой каталог, к которому нет общего доступа по ftp.
Решение состоит в том, чтобы создать правило для события OnFileUploaded :
- выберите Добавить (+ на панели инструментов)
- выберите событие OnFileUploaded в выпадающем списке
- выберите скрипт или приложение, которое будет перемещать файл в другое место или введите "c:\temp\movescript.bat $USR_FILE_83"
- создайте movescript.bat : откройте Блокнот, выберите Меню / Новый, запишите "move %1 c:\safeplace\", щёлкните Меню / Сохранить как, введите c:\temp\movescript.bat.

Каждый раз, как файл будет закачан, он будет перемещён в c:\safeplace\

Эта опция поддерживает теги из главы "Теги и настройка", вы не можете использовать все теги из-за их свойств.

14 - Скрипты

624x436 (11347 bytes)

Для получения дальнейшей информации обратитесь к главе : Скрипты

15 - Команды SITE

﻿ Щёлкните, чтобы задать новую команду SITE

Доступные теги командной строки :

$_ : число параметров.
$0 : параметры не анализируются.
$1 : параметр 1
...
$n : параметр n

Вы также можете использовать общие теги : Теги

Если вы хотите, чтобы вывод приложения был доступен пользователю, установите флажок "перенаправить вывод приложения клиенту". Сервер предполагает, что команда возвращает форматированный вывод (с кодом ошибки).
Также полезно задать таймаут, если приложение слишком долго работает.

16 - Настройки безопасности

624x436 (12239 bytes)

Блокировать временно запрещённые IP : Заблокированные IP-адреса/Узлы (автоматическая блокировка или список запрещённых) не будут получать сообщений от сервера, они просто игнорируются.
Изменять IP для данных в соответствии с исходным IP клиента : В соответствии с IP-адресом клиента (LAN/WAN), будет изменен IP передачи данных для минимизации проблем. Используется в ответе на команду PASV.
Преобразовывать IP-адрес клиента : Определять имя узла по IP-адресу (80.65.230.10 = ns0.gene6.net)
Чередовать передачи по всем доступным IP-адресам : При начале передачи из всех доступных IP будет выбран локальный для балансировки загрузки.
Невидимые сокеты : Сервер будет невидим для заблокированных пользователей, как если бы он был выключен.

17 - Привязка IP

Важная часть домена.

624x436 (13405 bytes)

Чтобы запустить домен, необходимо выбрать IP, порт и протокол. Щёлкните по кнопке Добавить.

В качестве IP можно указать * (все доступные IP; просто, если у вас всего один домен) или IP из списка доступных IP.

Важное замечание : если вы используете маршрутизатор, бесполезнл здесь вводить ваш публичный IP, т.к. он соотнесён не с вашим компьютером, на котором запущен FTP-сервер, а с маршрутизатором; компьютеру назначен локальный приватный IP (см. раздел Учебные пособия, чтобы правильно настроить сервер, находящийся за маршрутизатором).

По умолчанию используется 21 порт (стандартный порт FTP), но вы можете выбрать и другой порт для вашего домена (1021, 2156, 65021 ...)

Домен может прослушивать несколько различных IP и портов по разным протоколам, просто добавьте новые записи, чтобы начать использовать другие IP/порты/протоколы.

Безопасность : выбор протокола :

Только стандартные сессии FTP : обычный протокол FTP, соответствует RFC959, воспринимается всеми FTP-клиентами.
Только стандартные сессии FTP, разрешить явное (explicit) SSL-шифрование : в дополнение к FTP, явное SSL-шифрование может использоваться для повышения уровня безопасности. Клиент при необходимости может запросить сервер переключиться в безопасный режим SSL.
Неявное (implicit) SSL-шифрование : различие между данным режимом и предыдущим состоит в том, что SSL не может быть отключён, клиент может общаться с сервером только при помощи SSL, всё шифруется.
Только явное SSL-шифрование : только шифрованная явная передача SSL, запрещены обычные соединения. Как только клиент получает приглашение сервера (220 Gene6 FTP Server v3.0.0 (Build 34) ready...), он должен передать команду AUTH, требующую шифрования всей информации начиная с текущего момента, таким образом, шифруются логин и пароль.

Рекомендуемые значения по умолчанию : *, 21, Только стандартные сессии FTP, разрешить явное (explicit) SSL-шифрование.

Пассивный режим :

Отключить пассивный режим : вы можете захотеть отключить соединения в пассивном режиме, хотя это и не является хорошей идеей.
Перенаправить PASV IP : при нахождении за маршрутизатором, публикуемый в пассивном режиме IP может не является корректным публичным IP, назначенным вам; эта опция позволяет ввести ваш реальный IP или имя узла для IP пассивного режима.
Диапазон портов для пассивного режима : уменьшение диапазона открытых для пассивного режима портов может быть полезно, если используется брандмауэр или маршрутизатор. При использвовании маршрутизатора, данный диапазон портов следует перенаправить.

Активный режим :

Разрешить соединения к портам < 1024 : т.к. порты < 1024 могут резервироваться узлом для служб, таких как pop3, smtp, http, то резервирования портов для данных на незанятые порты может послужить причиной невозможности подключения к данным службам . (этот метод может использоваться для сканирования 3е-стороннего узла)

18 - Доступ по IP

﻿

Задание ограничений, таких как доступ по IP, позволяет вам запретить доступ или разрешить доступ только пользователям, которым вы доверяете.
Права могут назначаться как по IP, так и по имени узла.

Например :

+*.gene6.net (единственное правило) позволяет любому пользователю с доменным именем gene6.net подключиться к серверу; всем, кто не соответствует правилу, доступ будет запрещён.

-*.gene6.net (единственное правило) позволяет подсоединяться всем, кроме пользователей домена gene6.net.

Вы также можете использовать символы *,?,[x-y] в масках : [192-193].16?.[0-10].*, *.net?.nerim.fr - это допустимые маски.

Имена, задаваемые в списке доступа по IP, не определяются во время работы. Сервер берёт IP клиента, обращает DNS и сравнивает со списком доступа к IP/домену. Домен dyndns работает только в направлении от Имени к IP, по IP нельзя определить доменное имя dyndns, обычно только доменное имя провайдера, например, 12-20-14-25.yourisp.com.

19 - SSL

SSL, протокол защищенных сокетов, - это метод шифрования, используемый в G6FTP Server для шифрования ваших данных.
Для использования SSL необходимо прежде всего создать сертификат и подписать его.
Использование SSL в передачах данных гарантирует, что эти данные не могут быть прочитаны никем помимо получателя.
(см. : http://developer.netscape.com/tech/security/ssl/howitworks.html)

Вам также потребуется FTP-клиент, поддерживающий SSL, для установки подключения между клиентом и сервером.

624x436 (10849 bytes)

Сертификаты :

Файлы сертификата и ключа : выберите сертификат, который вы создали через Управление сертификатами.


Глава VI - FTP-сервер

1 - Обзор

FTP Сервер - это хранилище основных настроек; параметры, заданные здесь, применяются ко всем вашим доменам. Здесь определяются настройки ограничения скорости, заблокированные файлы, доступ по IP, статистика.

630x461 (12712 bytes)

Выбор любой основной категории (FTP Сервер, Безопасность) приведет к отображению страницы с описанием подкатегорий.

2 - Настройки

624x436 (8548 bytes)

Разное

Размер буфера для клиента : Размер буфера передачи/приёма (4 КБ) (не изменяйте данный параметр, не получив на то прямых указаний от службы поддержки)
Макс. строк в журнале домена : Сколько строк журнала отображать в журнале домена (примечание: задание большого значения приведёт к задержке при получении журналов с сервера).

Сокеты

Размер буфера для получения : Размер буфера сокетов для приёма (SO_SNDBUF) (не изменяйте данный параметр, не получив на то прямых указаний от службы поддержки)
Размер буфера для передачи : Размер буфера сокетов для передачи (SO_RCVBUF) (не изменяйте данный параметр, не получив на то прямых указаний от службы поддержки)

3 - Заблокированные файлы

Как и остальные настройки уровня FTP-сервера, данный список будет применён ко всем доменам сервера.

624x436 (8003 bytes)

﻿ Заблокированные файлы - это файлы, которые не могут храниться на сервере.
Вы можете задать маску файлов/пути (поддерживаются ?, *) : *.jpg, c:\path\images_200?\

Примечания :
- правила не применяются к загрузкам, только к закачке на сервер
- правила также применяются при переименовании файла

4 - Скорость передачи

624x436 (7893 bytes)

Наибольшая скорость :

Здесь можно определить ограничение скорости (загрузок и закачек), так чтобы весь сервер (все домены, расположенные на сервере) не превышали установленной шириины полосы пропускания.

Загрузка : наибольшая скорость, с которой сервер будет отдавать файлы пользователям.
Закачка : наибольшая скорость, с которой пользователь сможет закачивать файлы в домены.

5 - Статистика

624x436 (9647 bytes)

﻿ Подключения : число соединений.

Логины : количество пользователей, вошедших с данным логином.
Неудачные попытки входа : число неудачных подключений.

В данный момент подключено : число пользователей, подключённых к серверу в настоящее время.

Последнее подключение : дата последнего подключения.
Последнее имя пользователя : последний использованный логин (для псевдонимов).
Последний IP : последний известный IP.

Неудачных/прерванных закачек : число неудачных закачек.
Файлов закачано на сервер : число закачанных файлов.
Закачано : количество закачанной информации (байт).

Неудачных/прерванных загрузок : число неудачных загрузок.
Файлов загружено : число загруженных файлов.
Загружено : количество загруженной информации (байт).

Вы можете скопировать текущую статистику в буфер обмена или сбросить её при помощи кнопок панели инструментов.

6 - Доступ по IP

624x436 (8154 bytes)

Правила доступа по IP будут применены ко всем вашим доменам, это означает, что данные настройки доминирующие, следовательно, можно не определять правила для каждого домена.
(если вы зададите правило блокировки на уровне сервера и правило доступа на уровне домена, доступ будет запрещён, т.к. настройки сервера приоритетнее).

﻿

Задание ограничений, таких как доступ по IP, позволяет вам запретить доступ или разрешить доступ только пользователям, которым вы доверяете.
Права могут назначаться как по IP, так и по имени узла.

Например :

+*.gene6.net (единственное правило) позволяет любому пользователю с доменным именем gene6.net подключиться к серверу; всем, кто не соответствует правилу, доступ будет запрещён.

-*.gene6.net (единственное правило) позволяет подсоединяться всем, кроме пользователей домена gene6.net.

Вы также можете использовать символы *,?,[x-y] в масках : [192-193].16?.[0-10].*, *.net?.nerim.fr - это допустимые маски.

Имена, задаваемые в списке доступа по IP, не определяются во время работы. Сервер берёт IP клиента, обращает DNS и сравнивает со списком доступа к IP/домену. Домен dyndns работает только в направлении от Имени к IP, по IP нельзя определить доменное имя dyndns, обычно только доменное имя провайдера, например, 12-20-14-25.yourisp.com.


Глава VII - Информация FTP сервера

1 - Обзор

Здесь приведён общий обзор и статус всех запущенных доменов : создание сертификатов SSL, текущая лицензия, доступные плагины, журнал запуска, а также суммарная ширина полосы пропускания, используемая всеми доменами.

208x209 (4761 bytes)

2 - Сертификаты

Сертификаты используются для шифрования данных между пользователем и сервером. Без серфтификатов нельзя использовать подключения SSL. SSL, используемый в G6FTP Server, аналогичен используемому в протоколе https, когда вы делаете онлайн-покупки при помощи кредитной карты.
(см. : http://developer.netscape.com/tech/security/ssl/howitworks.html)

Щёлкните правой клавишей и выберите "Создать сертификат" в списке сертификатов, появится окно создания сертификата.

Имя сертификата : Имя сертификата будет отображаться в списке при указании сертификата в "Привязке IP".

Дата истечения : валидность сертификата, после указанного срока сертификат будет считаться недействительным.

Например : введите имя "ftp.domain.com" , оставьте поле даты истечения без изменений (по умолчанию дата установлена на 10 лет вперёд).

Нажмите Далее :

Отобразится новое окно, запрашивающее информацию для настройки сертификата.

Город : Введите название населённого пункта. (Например, Los Angeles)
Область/Округ : Введите название области или округа. (Например, California)
Страна : Введите сокращённое название страны. (Например, US, FR)
Стандартное имя : здесь можно ввести как имя человека, создающего сертификат, так и точное доменное имя сервера, связанного с узлом.
Email : Адрес e-mail человека, которому принадлежит сертификат.
Организация : Введите название вашей организации или имя пользователя.
Штат : Введите штат вашей организации. (Например, Research and Development)

Следует заполнить все поля, иначе вы не сможете создать сертификат.

Нажмите "Завершить", сертификат теперь доступен в списке сертификатов.

Теперь вы можете использовать этот сертификат в Свойствах домена / Привязка IP, протокол, SSL.

3 - Лицензия

Лицензия, установленная на администрируемом сервере, отображается здесь.
Она отображает зарегистрированное имя в вашей компании (кто приобрёл программу), число зарегистрированных лицензий (1 для каждой машины, на которой запущена программа) (см. : http://www.g6ftpserver.com/?page=purchase)

4 - Журнал

Журнал запуска сервера, если что-то пойдёт не так, это будет отображено в данном журнале.

Пример :

Gene6 FTP Server v3.0.0 (Build 34) - Copyright (c) 1998-2004 Gene6 SARL
Windows NT 5.1 Service Pack 1
1xIntel(R) Celeron(R) CPU 2.20GHz 2191 Mhz
Using WinSock 2.0
Accounts storage : 'Inifiles v2.8'.
SSL loaded. Version : OpenSSL 0.9.7d 17 Mar 2004
Starting domain 'ftp.us.gene6.com'.

5 - Плагины

Здесь приводится список доступных плагинов, обнаруженных при запуске сервера.

510x345 (8351 bytes)

Использование описывается в соответствующих настройках.

6 - Статус

Три вкладки отображают различную информацию.

Статус :

Здесь можно проверить статус всего сервера, общее число соединённых пользователей, скорости входящих/исходящих подключений, количество полученных/переданных байт, время работы ...

IP :

Список доступных и назначенных IP вашего компьютера, на котором запущен G6FTP Server.

IP домена :

Текущие используемые доменами IP, а также используемые порты.
(IP и порт могут быть изменены в Свойствах домена / Привязка IP).


Глава XI - Интерфейс учётных записей групп

1 - Учётные записи групп

Если вы хотите, чтобы несколько пользователей имели одни и те же права доступа на вашем FTP-сервере, можно настроить групповую учётную запись дял всех, это гораздо проще, чем настраивать одни и те же опции для каждой пользовательской учётной записи. Это удобный и простой метод управления большим числом пользователей / правами пользователей.

Примечание :
- вы не можете подключиться к серверу под учётной записью группы, требуется подключиться под учётной записью пользователя, являющегося членом группы.
- можно иметь неограниченное число групп, один и тот же пользователь может являться членом нескольких групп.

Создание :

В домене : выберите папку Группы, щёлкните правой клавишей мыши, выберите "Создать", появится новое окно, запрашивающее имя новой учётной записи группы.

630x460 (13848 bytes)

Выбор любой основной категории (Группа, Настроить, Безопасность) приведет к отображению страницы с описанием подкатегорий.

2 - Права доступа

Права группы назначаются всем пользователям группы при подключении, однако возможно указание специальных прав доступа пользователю в учётной записи пользователя.

Результат будет следующим : права доступа пользователя + права доступа группы.

Note :
- права доступа пользователя всегда имеют приоритет над правами группы.
- если в учётной записи пользователя переопределены права доступа, то права доступа пользователя перезапишут права доступа группы)

См. : Виртуальная файловая система

3 - Доступные файлы

Данная опция аналогична соответствующей в учётной записи пользователя.

Доступные для группы файлы будут добавлены в список доступных файлов пользователя.

4 - Заблокированные файлы

Данная опция аналогична соответствующей в учётной записи пользователя.

Заблокированные для группы файлы будут добавлены в список заблокированных файлов пользователя.

5 - Примечания

Здесь вы можете разместить некоторую информацию о группе.

6 - Скрипты

Данная опция аналогична соответствующей в учётной записи пользователя.

Скрипты группы будут добавлены к списку скриптов пользователя.
(группам и пользователям доступны одинаковые скрипты)

7 - команды SITE

Данная опция аналогична соответствующей в учётной записи пользователя.

Команды SITE группы будут добавлены к командам SITE пользователя.
(Команды SITE пользователя перезапишут команды SITE группы с тем же именем)

8 - Доступ по IP

Данная опция аналогична соответствующей в учётной записи пользователя.

Правила доступа по IP для группы будут добавлены к правилам доступа пользователя по IP.
(Правила доступа пользователя по IP перезапишут групповые правила доступа по IP в случае, если встретится одинаковый IP/Узел)


Глава III - Начало работы

1 - Обзор

В этой главе будет кратко описан интерфейс администрирования G6FTP Server.

В G6FTP Server два основных приложения:
- движок FTP-сервера
- FTP Администратор

Движок FTP-сервера работает прозрачно (без интерфейса) и доступен при помощи Администратора.
Однажды установленный, FTP-сервер будет работать как служба (это означает, что он запускается, как только загружается Windows, до входа пользователей в систему).
Администратор может быть запущен через меню Пуск / Программы / Gene6 FTP Server / Administration.

2 - Структура

После установки программы вы можете запустить удалённое администрирование (если выберете соответствующую возможность в конце установки; если Администратор не запущен, вы можете запустить его при помощи меню Пуск / Gene6 FTP Server).

Настройки интерфейса и сервера :

Левая панель наиболее важна, она содержит перечень всех основных пунктов.

274x545 (12569 bytes)

Как только вы выберете основной пункт, в правой панели раскроется его структура.

Правила:

FTP сервер :
- Настройки применяются ко всем доменам (доминирующие настройки).
- Сертификаты доступны в свойствах всех доменов в п. Настройки SSL.
- Журнал отображает информацию о запуске сервера.
- Плагины отображает список доступных плагинов (расположенных в каталоге /plugins), плагины доступны всем доменам данного сервера.
- Статус отображает статистику для всех доменов.

Домены :
- Настройки применяются ко всем пользователям/группам (доминирующие настройки).

3 - Основы

Запущенный FTP-сервер состоит из двух основных вещей :

- домен (например, ftp.gene6.com)
- как минимум одна учётная запись

Затем, в зависимости от ваших нужд, вы можете добавить поддержку SSL, а также создать новые учётные записи, группы.

Что следует знать перед запуском сервера :
- будет ли это публичный FTP сервер ? или приватный ?
- будет ли узел содержать несколько доменов ?
- нужна ли вам анонимная учётная запись ?
- нужно ли вам шифрование ?
- находитесь ли вы за маршрутизатором, в локальной сети ?

Теперь вы готовы рассмотреть доступные свойства программы.


Глава II - Установка

1 - Установка программы

Для установки G6FTP Server на ваш сервер загрузите архив с веб-сайта и запустите программу установки.
Учтите, что вам потребуются права администратора.

Если вы получаете сообщение об ошибке, в котором заявляется, что копия G6FTP Server уже запущена, остановите службу (через меню Пуск) и снова запустите установку.

501x383 (12233 bytes)

Просмотрите Лицензию и Информацию о текущей версии программы, затем выберите установочный каталог.

501x383 (12632 bytes)

Выберите компоненты для установки :
- если это новая установка, оставьте значения по умолчанию.
- если вы устанавливаете Администратор для доступа к вашему серверу с другого компьютера, вам не требуется устанавливать движок сервера и трей-монитор (Tray Monitor).

501x383 (11536 bytes)

Выберите, следует ли запускать Tray Monitor при загрузке системы, нужно ли создавать ярлыки и подгруппу в меню Пуск.

501x383 (10325 bytes)

Установка ... При обновлении будут заданы вопросы о замене некоторых файлов (обычно скриптов по умолчанию и языкового файла).

501x383 (9096 bytes)

Последний шаг, установка программы завершена, вы можете начать ее использование.

501x383 (12253 bytes)

2 - Устанавливаемые компоненты

/accounts : содержит файлы ваших доменов и учётных записей.
/administrative tools : содержит .bat-файлы для запуска и остановки службы.
/backup : если вы обновляли программу, то данный каталог содержит старые версии файлов (сервер и клиент удалённого администрирования).
/certificates : содержит сертификаты SSL, созданные при помощи Администратора.
/help : содержит файлы справки.
/log : содержит журналы сервера и администрирования.
/plugins : содержит расширения (плагины), используемые сервером.
/remoteadmin : содержит сертификаты SSL, используемые удалённым администратором.
/scripts : содержит скрипт-файлы, которые могут использоваться сервером.
/uninstall : удаление программы.

G6FTPAdmin.exe : клиент удалённого администрирования.
G6FTPServer.exe : движок сервера.
G6FTPTray.exe : трей-монитор, дающий отчёт о локальном сервере.
languages.sib : языковые файлы для локализованных версий.
libeay32.dll : SSL dll.
libssl32.dll : SSL dll.
license.txt : файл лицензии.
remoteadminserver.dll : dll, используемая для удалённого администрирования.
version.txt : описание изменений между версиями.

3 - Удаление

Запустите соответствующий ярлык из группы G6FTP Server в меню Пуск для удаления программы.
Вы также можете очистить каталог установки после успешного удаления, т.к. новые файлы, созданные после установки, не будут удалены программой удаления.


Глава I - Введение

1 - Что такое Gene6 FTP Server

Gene6 FTP Server v3.0 - это профессиональная версия программы G6FTP Server, нашего основного продукта, разработка которого начата в 1998.

Это полнофункциональный FTP-сервер для Microsoft Windows NT/2000/XP/2003. Программа позволяет вам обеспечить безопасный доступ к вашим файлам через Интернет.

Вы можете управлять доступом при помощи учётных записей пользователей/групп; каталогов; создания нескольких виртуальных узлов FTP; задания ограничений, таких как время доступа в день, доступ по IP ...

G6FTP Server соответствует Интернет-стандартам протокола FTP. Поддерживаемые Запросы на комментарии (RFC) : RFC-775, RFC-959, RFC-1123, RFC-2228, RFC-2389, RFC-2428, RFC-2577, RFC-2640 (только UTF8).
(см. : http://www.rfc-editor.org/)

2 - Безопасность

При разработке G6FTP Server уделялось пристальное внимание вопросам безопасности. Ниже приведены некоторые возможности безопасности :
  • Шифрование SSL (явное/неявное) может использоваться для обмена важными файлами.
  • Ограничения доступа, основанные на IP/Узле.
  • Управление правами доступа для файлов/каталогов.
  • Удалённое администрирование по безопасному соединению.
  • Административные учётные записи (администратор, супер администратор).
  • Авторизация NT (использование пароля Windows).
  • Единовременные пароли (OTP, S/Key) (MD5).
  • Ограничение числа соединений (для IP, домена, пользователя).
  • Ограничение срока действия учётной записи.
  • Встроенные команды проверки целостности (CRC, MD5).

    3 - Управление удалённым сервером

    Поскольку вы не всегда физически можете получить доступ к компьютеру, на котором запущен G6FTP Server, были разработаны средства удалённого администрирования, позволяющие вам добавлять, изменять, удалять учётные записи пользователей, а также изменять все доступные настройки ваших доменов, как если бы вы находились у компьютера, на котором запущен сервер.

    Преимущество состоит единообразии интерфейса как для локальных, так и для удалённых подключений.

    Вы также можете делегировать администрирование другому администратору, создав новую учётную запись пользователя с ограниченными правами администратора (см. Администратор сервера)

    Подключение удалённого администрироания шифруется при помощи SSL и запускается на собственном настраиваемом порту.

    4 - Системные требования

    • Операционная система : Windows NT4.0 (SP6a, workstation/server), Windows 2000 (pro/server/adv. server), Windows XP (home/pro), Windows 2003 (std/server).
    • Процессор : Intel, AMD (рекомендуется PIII 500 МГц).
    • Память : Минимум 64 Мб системной памяти (рекомендуется 128 Мб в зависимости от используемой ОС).
    • Дисковое пространство : Минимум 15 Мб свободного дискового пространства (для программных и рабочих файлов).
    • Интернет - подключение : модем (28.8k), кабельный, adsl или лучше (рекомендуется dsl/кабельный).
    • Сеть : сетевые компоненты Microsoft's 32-бит TCP/IP. Winsock 2.0.

    5 - Обновление

    Новые версии программы по мере выхода доступны для скачивания на веб-сайте.
    См. : http://www.g6ftpserver.com/?page=download

    6 - Изменения и история версий

    Изменения отражаются в файле Version.txt, который можно просмотреть при установке программы, после установки этот файл можно найти в установочном каталоге. Также изменения можно просмотреть по адресу http://www.g6ftpserver.com/?page=files/version.txt

    7 - Техническая поддержка

    Если вы сталкиваетесь с какой-либо проблемой, прежде всего, обратитесь к FAQ (Часто задаваемые вопросы) - http://www.g6ftpserver.com/?page=faq или свяжитесь с нами : http://www.g6ftpserver.com/?page=support

    8 - Авторские права

    Gene6, Sarl
    33 rue de Jemmapes
    C22
    59800 Lille
    France

    Веб-страница : http://www.Gene6.com - http://www.G6FTPServer.com

    Информация, содержащаяся в данном документе, может быть изменена без уведомления и не может рассматриваться как обязательство Gene6, Sarl. Несмотря на то что все усилия были направлены на обеспечение гарантии правильности информации, приведённой здесь, Gene6, Sarl не несёт ответственности за ошибки или упущения. Gene6, Sarl. не несёт никакой ответственности за урон, причинённый использованием информации, содержащейся в данном документе.
    Программное обеспечение, описанное в этом документе, выпускается по лицензии и не может быть использовано или скопировано иначе, чем описано в лицензии.
    Gene6 FTP Server, Авторские права © 2004, Gene6, Sarl Все права защищены.
    Другие названия продуктов или компаний могут являться или являются торговыми марками или зарегистрированными товарными знаками и являются собственностью соответствующих компаний.
    Никакая часть данной публикации не может быть воспроизведена, скопирована, помещена в поисковую систему или передана без предварительно выраженного письменного согласия Gene6, Sarl.

    (перевод на русский язык: Июнь 2004 Первая редакция )

    История печати :

    Февраль 2004 Первая редакция

    9 - Список разработчиков

    Список разработчиков :

    Файлы DLL OpenSSL содержат программы, разработанные OpenSSL Project для использования в OpenSSL Toolkit. (http://www.openssl.org/)
    Файлы DLL OpenSSL содержат криптографические программы, написанные Eric Young (eay@cryptsoft.com).
    Файлы DLL OpenSSL содержат программы Tim J. Hudson (tjh@cryptsoft.com).

    Данная программы использует zlib . Авторские права (C) 1995-2003 Jean-loup Gailly и Mark Adler (http://www.gzip.org/zlib/)

    Данная программы использует Tnt Delphi Unicode Controls, написанные Troy Wolbrink
    (http://home.ccci.org/wolbrink/tnt/delphi_unicode_controls.htm)

    Данная программы использует RecyclerMM, написанный Eric Grange - Creative IT (http://glscene.org)

    Благодарности :

    Благодарим всех специализированных тестеров и людей, поддерживающих рахзработку (порядок следования не имеет значения) :
    Supernature, KnuckleHead, Chico77, Eskimo, Jose, Tom Reiertsen, Mrzaz, James Hughes, Michael Pruefer, Mario, Misteriks, Adam Saunders, Alexander Zonin, Jason Choppert, Jonas Sladen и всех тех, о ком мы забыли упомянуть, но кто присылал баг-репорты и предложения по улучшению функциональности программы.


I - Введение

  1. Что такое Gene6 FTP Server
  2. Безопасность
  3. Управление удалённым сервером
  4. Системные требования
  5. Обновление
  6. Изменения и история версий
  7. Техническая поддержка
  8. Авторские права
  9. Список разработчиков

II - Установка

  1. Установка программы
  2. Устанавливаемые компоненты
  3. Удаление

III - Начало работы

  1. Обзор
  2. Структура
  3. Основы

IV - Администрирование

  1. Обзор
  2. Настройки
  3. Настройки журнала
  4. Привязка IP
  5. Доступ по IP

V - Администратор

  1. Обзор
  2. Мастер
  3. Пользователь с правами администратора
  4. Доступ по IP
  5. Права в домене

VI - FTP-сервер

  1. Обзор
  2. Настройки
  3. Заблокированные файлы
  4. Скорость передачи
  5. Статистика
  6. Доступ по IP

VII - Информация FTP сервера

  1. Обзор
  2. Сертификаты
  3. Лицензия
  4. Журнал
  5. Плагины
  6. Статус

VIII - Домены

  1. Обзор
  2. Мастер
  3. Настройки
  4. Аутентификация
  5. Разное
  6. Журналы и отчёты
  7. Сообщения
  8. Заблокированные файлы
  9. Псевдонимы пользователя
  10. Скорость передачи
  11. Предел передачи
  12. Статистика
  13. События
  14. Скрипты
  15. Команды SITE
  16. Настройки безопасности
  17. Привязка IP
  18. Доступ по IP
  19. SSL

IX - Информация домена

  1. Обзор
  2. Активность
  3. Журнал
  4. Временный запрет (бан)
  5. Передачи

X - Интерфейс учётных записей пользователя

  1. Учётные записи пользователей
  2. Мастер
  3. Настройки
  4. Права доступа
  5. Разное
  6. Дополнительно
  7. Заблокированные файлы
  8. Доступные файлы
  9. Квота, пропорции
  10. Скорость передачи
  11. Предел передачи
  12. Время доступа в день
  13. Примечания по учёнтной записи
  14. Статистика
  15. Скрипты
  16. Команды SITE
  17. Доступ по IP
  18. Категория (класс) пользователей

XI - Интерфейс учётных записей групп

  1. Учётные записи групп
  2. Права доступа
  3. Доступные файлы
  4. Заблокированные файлы
  5. Примечания
  6. Скрипты
  7. команды SITE
  8. Доступ по IP

XII - Виртуальная файловая система

  1. Как это работает
  2. Доступные ресурсы
  3. Права доступа
  4. Дополнительно

XIII - Скрипты

  1. Как это работает
  2. Доступные ресурсы
  3. Пример

XIV - Теги и настройка

  1. Как это работает
  2. Доступные теги
  3. Пример

XV - Учебные пособия

  1. Импорт учётных записей пользователей версий v2.x
  2. Резервное копирование сервера
  3. Администрирование удалённого FTP-сервера
  4. Настройка при наличии маршрутизатора
  5. Настройка при наличии брандмауэра
  6. Включение SSL для домена

XVI - Документы

  1. Запросы на комментарии (RFC)
  2. Команды FTP
  3. Часто встречающиеся проблемы


Глава XIII - Скрипты

1 - Как это работает

Скрипты могут использоваться для реагирования на события и команды, доступные серверу.
Поддерживаемые скриптовые языки - VBScript, JScript.
Чтобы использовать скрипт, его необходимо поместить в каталог <установочный путь>/scripts/.

2 - Доступные ресурсы

Здесь приведён список вызываемых функций.

onSiteXXXXX , где XXXXX - это ваша команда SITE
Эта команда имеет место, когда пользователь вводит команду SITE (например, "SITE BLA test test2" вызовет функцию onSiteBla("test test2"))
Как производить анализ параметров, решаете вы.

Следующие функции вызываются без параметров :

OnClientConnected : клиент, только что подключённый к домену
OnClientDisconnected : клиент, отсоединившийся от домена
OnClientBanned : клиент пытался подключиться, но он заблокирован в домене
OnClientHammering : клиент превысил макc.число разрешенных соединений (hammer), заблокирован и отключён
OnSameIPConnect : клиент отключён, т.к. слишком много соединений с одного IP
OnTooManyClient : клиент отключён, т.к. слишком много соединений

OnClientTimeOut : клиент отключён по таймауту
OnClientLoggedIn : клиент только что авторизовался
OnDomainClosed : домен перешёл в режим автономной работы
OnDomainOpened : домен перешёл в режим работы в сети : домен прослушивает входящие подключения
OnDomainStarted : был создан домен
OnDomainStopped : был удалён домен
OnEveryDay, OnEveryHour : только вызов скриптов домена
OnDirCreated : был создан каталог
OnDirDeleted : был удалён каталог
OnFileBanned : клиент попытался закачать заблокированный файл
OnFileDeleted : клиент удалил файл
OnFileDownloaded : клиент закончил загрузку файла
OnFileRenamed : клиент успешно переименовал файл/каталог
OnFileUploaded : клиент закончил закачку файла
OnFileUploadFailed : клиент прервал операцию или при закачке произошла ошибка сокета
OnIPChanged : IP-адрес домена изменился
OnQuotaExceeded : клиент превысил квоту

Примечание:
Для каждого клиента создаётся экземпляр скрипта, поэтому 2 скрипта могут исполняться одновременно, затем файл может быть заблокирован другим скриптом, который открыл его.

Объекты, доступные в скриптах :

:-------------------------------------------------------------

Object Server

string CertificatePath : Возвращает путь к хранилищу сертификатов
string LogPath : Возвращает путь к хранилищу файлов журнала
string ScriptPath : Возвращает путь к хранилищу скриптов
string ServerPath : Возвращает путь к приложению

:-------------------------------------------------------------

Object Domain

int Bandwidth : Возвращает текущее использование полосы пропускания в байтах/с
int ClientCount : Возвращает число клиентов, подсоединённых к домену
string Name : Возвращает имя домена
date StartTime : Возвращает дату и время запуска домена

void WriteToLog(String log) : Если включено ведение журнала, пишет параметр в журнал

:-------------------------------------------------------------

Object Client

date ConnectedSince : Возвращает дату подключения
string HostName : Возвращает имя узла клиента (если включена опция ResolveIP)
string ID : Возвращает уникальный ID клиента
string PeerAddr : Возвращает одноранговый адрес клиента
int PeerPort : Возвращает одноранговый порт клиента

string LocalAddr : Возвращает локальный адрес клиента
int LocalPort : Возвращает локальный порт клиента
string Keyword : Возвращает текущую команду клавиатуры
string Directory : Возвращает текущий виртуальный каталог клиента
string DirectoryReal : Возвращает текущий путь клиента
boolean Logged : Возвращает true, если клиент вошёл на сервер
int RestartPos : Возвращает маркер позиции перезапуска
string Username : Возвращает имя клиента
string Filename : Возвращает текущее виртуальное имя (например, "/temp/file.txt")
string FilenameReal : Возвращает текущее имя файла (например, "C:\temp\file.txt")
int FileSize : Возвращает размер последнего переданного файла
int FilePosition
int TransferTimeSeconds : Возвращает время передачи в секундах
string TransferTime : Возвращает время передачи в виде "00:00:00"
int TransferSpeedBps : Возвращает скорость передачи в байтах/с
string TransferSpeed : Возвращает скорость передачи в КБайтах/с в виде "128 КБайт/с"

void ConvertToReal(string path) : Преобразовать виртуальный путь (например, /temp) в реальный (например, C:\Temp)
void Send(string Message) : Послать строку клиенту void send(string Message, int Code) : Послать FTP-форматированную строку клиенту, например, 200 ok

3 - Пример

'СКРИПТ: Log downloads.vbs
'АВТОР: Gene6
'ДАТА: 2002/10/04
'ОПИСАНИЕ: Записать каждую загрузку в файл журнала
' Каждая запись имеет следующий формат - "date time#username#filename#filenamereal#from#to#time#speed

'Константы
Delimiter = "#"
ForAppending = 8

'Создать путь к файлу
strYear = Year(Date)

strMonth = Month(Date)
' добавить лидирующий ноль if (strMonth < 10) Then
strMonth = "0" & strMonth
end if

strDay = Day(Date)
' добавить лидирующий ноль
if (strDay < 10) Then
strDay = "0" & strDay
end if

LogFilename = Server.LogPath & Domain.Name & "-" & strYear & "-" & strMonth & "-" & strDay & "-downloads.log"

sub OnFileDownloaded()
Set fso = CreateObject("Scripting.fileSystemObject")
Set LogObj = fso.OpenTextFile(LogFilename, ForAppending, true)

Line = FormatDateTime(Now) & Delimiter & Client.Username & Delimiter & Client.Filename & Delimiter & Client.FilenameReal & Delimiter & Client.RestartPos & Delimiter & Client.FilePosition & Delimiter & Client.TransferTime & Delimiter & Client.TransferSpeed

LogObj.WriteLine(Line)
LogObj.Close
end sub


Глава XIV - Теги и настройка

1 - Как это работает

Теги позволяют настраивать приветствия и иные сообщения FTP-сервера.
Это удобно для просмотра различной информации, например, свободного места на диске, числа подключённых пользователей.

2 - Доступные теги

Разделитель тегов : $ (Например, $SYS_CPU)

SYS_CPU : тип и номер процессора сервера (читается из реестра windows).

SYS_CPUNAME : имя процессора.
SYS_CPUNB : число процессора.
SYS_CPUMHZ : частота процессора.

SYS_RAM[BYTE|KB|MB|GB] : память сервера в байтах, КБ, МБ, ГБ.
SYS_RAM : память сервера в байтах
SYS_OS : версия ОС

SRV_NAME : имя сервера.
SRV_VERSION : версия сервера.
SRV_UPTIME : время работы сервера.

SRV_STATSCONNECTIONS : общее число подключений.
SRV_STATSLOGINS : общее число логинов.

SRV_STATSDOWNLOADED : всего загружено со всего сервера (форматированно).
SRV_STATSDOWNLOADED[BYTE|KB|MB|GB] : всего загружено со всего сервера в байтах, КБ, МБ, ГБ.

SRV_STATSUPLOADED : всего закачано на весь сервер (форматированно).
SRV_STATSUPLOADED[BYTE|KB|MB|GB] : всего закачано на весь сервер в байтах, КБ, МБ, ГБ.

SRV_STATSFDOWNLOADED : всего файлов загружено со всего сервера.
SRV_STATSFUPLOADED : всего файлов закачано на весь серверr.

Домен

DOM_NAME : имя домена.
DOM_CLIENTCOUNT : число клиентов, подключённых к домену
DOM_MAXUSERS : макс. допустимое число пользователей домена.
DOM_IPS : IP, используемый доменом.
DOM_WHO : Список клиентов, подключённых к домену.

DOM_SPEED : текущая скорость всего домена (форматированно)
DOM_SPEED[BYTE|KB|MB|GB] : текущая скорость всего домена в байтах, КБ, МБ,ГБ

DOM_AVGSPEED : средняя скорость (форматированно).
DOM_AVGSPEED[BYTE|KB|MB|GB] : средняя скорость в байтах, КБ, МБ,ГБ.

DOM_DOWNLOADED : загружено (форматированно).
DOM_DOWNLOADED[BYTE|KB|MB|GB] : загружено байт, КБ, МБ,ГБ.

DOM_UPLOADED : закачано (форматированно).
DOM_UPLOADED[BYTE|KB|MB|GB] : закачано байт, КБ, МБ,ГБ.

DOM_FDOWNLOADED: число загруженных файлов со времени запуска домена.
DOM_FUPLOADED: число закачанных файлов со времени запуска домена.

SOM_STATSCONNECTIONS : общее число подключений.
SOM_STATSLOGINS : общее число логинов.

DOM_STATSDOWNLOADED[BYTE|KB|MB|GB]: всего загружено со времени создания домена.
DOM_STATSUPLOADED[BYTE|KB|MB|GB]: всего закачано со времени создания домена.
DOM_STATSFDOWNLOADED: всего файлов загружено со времени создания домена.
DOM_STATSFUPLOADED: всего файлов закачано со времени создания домена.

DOM_EVENT : возвращает запущенное событие (onFileUploaded, ...)

LOG_OLDFILENAME: старое имя файла для события OnLogRotated.
LOG_NEWFILENAME: новое имя файла для события OnLogRotated.

Учётная запись

USR_ACCOUNT : имя учётной записи.
USR_GROUP : имя группы.
USR_CLASS : имя категории.

USR_RATIOCOUNTMETHOD : тип исользуемой пропорции. (подсчёт байт в сессию ...)

USR_RATIOUP : пропорция закачки.
USR_RATIODOWN : пропорция загрузки.

USR_QUOTACURRENT : текущая квота (форматированно).
USR_QUOTACURRENT[BYTE|KB|MB|GB] : текущая квота в байтах, КБ, МБ,ГБ.

USR_QUOTAMAX : макс.квота (форматированно).
USR_QUOTAMAX[BYTE|KB|MB|GB] : макс.квота в байтах, КБ, МБ,ГБ.

USR_QUOTAAVAILABLE : доступная квота (форматированно).
USR_QUOTAAVAILABLE[BYTE|KB|MB|GB] : доступная квота в байтах, КБ, МБ,ГБ.

USR_STATSLOGINS : общее число логинов.

USR_STATSFUPLOADED : файлов закачано на сервер.
USR_STATSUPLOADED : закачано (форматированно).
USR_STATSUPLOADED[BYTE|KB|MB|GB] : закачано байт, КБ, МБ,ГБ.

USR_STATSFDOWNLOADED : файлов загружено.
USR_STATSDOWNLOADED : загружено (форматированно).
USR_STATSDOWNLOADED[BYTE|KB|MB|GB]: загружено байт, КБ, МБ,ГБ.

USR_TIMEOUT : время таймаута.

USR_INAME : Имя пользователя (из примечаний).
USR_IADDRESS : Адрес пользователя (из примечаний).
USR_ICITY : Город пользователя (из примечаний).
USR_ICOMPANY : Компания пользователя (из примечаний).
USR_IPHONEHOME : Домашний телефон пользователя (из примечаний).
USR_IPHONEWORK : Рабочий телефон пользователя (из примечаний).
USR_IFAX : Факс пользователя (из примечаний).
USR_IEMAIL : email пользователя (из примечаний).
USR_INOTES : Заметки о пользователе (из примечаний).

Клиент

(если пользователь успешно авторизовался, то также доступны теги Учётной записи)

KEYWORD : команда, отправленная клиентом.

USR_FDOWNLOADED : файлов загружено за текущую сессию.
USR_FUPLOADED : файлов закачано за текущую сессию.

USR_ACCOUNT : используемая учётная запись.
USR_NAME : имя, отправленное в качестве логина.
USR_PASS : используемый пароль.
USR_DIR : текущий реальный каталог.
USR_PWD : текущий каталог.
USR_FILENAME : текущий передавающийся файл.

USR_ID : id, присвоенный пользователю сервером.
USR_PEERIP : IP пользователя.
USR_PEERIP_000 : IP пользователя в виде 192.168.000.010 (для использования в именах файлов, сортировках)..
USR_PEERPORT : порт пользователя.
USR_LOCALIP : IP, к которому подсоединён пользователь.
USR_LOCALPORT : порт, к которому подсоединён пользователь.
USR_HOSTNAME : Имя узла, определённое по IP пользователя.
USR_TIMEONLINE : время соединения.

USR_CPU : отображает процессорное время, использованное клиентом, в формате "секунды.миллисекунды",

USR_DOWNLOADED : загружено (форматированно).
USR_DOWNLOADED[BYTE|KB|MB|GB] : загружено байт, КБ, МБ,ГБ.
USR_UPLOADED : закачано (форматированно).
USR_UPLOADED[BYTE|KB|MB|GB] : закачано байт, КБ, МБ,ГБ.

USR_SPEED : текущая скорость передачи для пользователя (форматированно).
USR_SPEED[BYTE|KB|MB|GB] : текущая скорость передачи для пользователя, байт/с, KБ/с, MБ/с, ГБ/с.
USR_AVGSPEED : средняя скорость (форматированно).
USR_AVGSPEED[BYTE|KB|MB|GB] : средняя скорость, байт/с, KБ/с, MБ/с, ГБ/с.

USR_FREESPACE[BYTE|KB|MB|GB] : свободное место в текущем каталоге, байт, КБ, МБ,ГБ.

USR_RATIOCREDIT : возвращает доступный кредит в байтах (форматированно) или числе файлов.

(теги FILE содержат имя каталога или файла, для событий)

USR_FILE : полный путь к файлу (включая имя файла).
USR_FILE_83 : То же, что и USR_FILE, но путь в формате 8.3.
USR_FILENAME : только имя файла (archives.zip, archives.rar ...).
USR_FILENAME_83 : То же, что и FILENAME, но путь в формате 8.3.
USR_FILEEXT : расширение файла в верхнем регистре (.EXE, .RAR ...).
USR_FILENOEXT : имя файла без расширения.
USR_FILEPATH : путь без имени файла (c:\temp\ ...).
USR_FILEPATH_83 : То же, что и FILEPATH, но путь в формате 8.3.
USR_FILESIZE : размер файла в байтах.

Время

HH : час 00-23.
NN : минута 00-59.
SS : second 00-59.

D : день 1-31.
DD : день 01-31.
ENGDD : Английский порядковый суффикс ко дню месяца, 2 символа (st, nd, rd, или th)
M : месяц 1-12.
MM : месяц 01-12.
YY : год 00-99.

WEEK : YY-MM-DD, эта дата меняется каждое воскресенье, так что дата только одна на всю неделю.
WEEKR : DD-MM-YY, так же, как и WEEK, но Год и День в других местах.
DATE : DD/ММ/YY
TIME : HH:NN:SS
NOW : Дата + Время

DAY : день Понедельник/Вторник ... (используются локальные настройки).
ENGDAY : день Monday/Tuesday ... (всегда по-английски).
MONTH : месяц January/February ... (используются локальные настройки).
ENGMONTH : месяц January/February ... (всегда по-английски).
YEAR : год 0-2003

3 - Пример

Здравствуйте, $USR_ACCOUNT! Вы подключены к $SRV_NAME, $SRV_VERSION, время работы сервера $SRV_UPTIME.
Вы подключились к домену $DOM_NAME, в настоящее время $DOM_CLIENTCOUNT (/$DOM_MAXUSERS) клиентов.
Локальное время $TIME, текущая скорость передачи $DOM_SPEED.


Глава XV - Учебные пособия

1 - Импорт учётных записей пользователей версий v2.x

Для импорта ваших учётных записей, созданных предыдущими версиями программы (v2.x), вам потребуются файлы users.ini, groups.ini, ftpsrv.ini, расположенные в каталоге, куда была установлена версия v2.x. Как только вы скопируете эти файлы в какой-либо каталог (назовём его c:\temp\), вы сможете импортировать настройки.

Домен :

- Откройте Администратор Gene6 FTP Server
- Выберите сервер
- Прейдите в Домены
- Перейдите в Главное меню / Сервис / Импорт, выберите Домен. Появится новый диалог
- Перейдите в c:\temp\ и выберите файл 'ftpsrv.ini'
- Нажмите Открыть, будет создан новый домен, его настройки будут основываться на соответствующих настройках предыдущей версии.

Пользователи :

- Откройте Администратор Gene6 FTP Server
- Выберите сервер
- Прейдите в Домены / Пользователи
- Перейдите в Главное меню / Сервис / Импорт / Пользователи. Появится новый диалог
- Перейдите в c:\temp\ и выберите файл 'users.ini'
- Нажмите Открыть, будет произведён импорт старых учётных записей с сохранением их настроек.

Группы :

- Откройте Администратор Gene6 FTP Server
- Выберите сервер
- Прейдите в Домены / Группы
- Перейдите в Главное меню / Сервис / Импорт / Группы. Появится новый диалог
- Перейдите в c:\temp\ и выберите файл 'groups.ini'
- Нажмите Открыть, будет произведён импорт старых учётных записей с сохранением их настроек.

Примечание : вам всё же потребуется проверить все учётные записи и их настройки перед запуском сервера, т.к. при переходе на новую версию было сделано множество изменений, поэтому импортированные учётные записи могут сразу не заработать.

2 - Резервное копирование сервера

Если вам требуется перенести программу с одного компьютера на другой, вам потребуется создать резервную копию настройк, учётных записей и доменов. Наилучший способ - просто сделать резервную копию установочного каталога программы, затем скопировать её в новое место и установить программу, для того чтобы восстановить ярлыки и переустановить службу.

Если вы хотите создать резервную копию некоторых настроек :

Вся информация о доменах и учётных записях хранится в файлах, расположенных в каталоге <установочный путь>\Accounts\
Сертификаты SSL хранятся в <установочный путь>\Certificates\
Учётные записи и настройки удалённого администрирования хранятся в <установочный путь>\RemoteAdmin\

Настройки клиента удалённого администрирвоания хранятся в реестре Windows.
Раздел : HKEY_CURRENT_USER\Software\Gene6\G6FTPAdmin

Как создать резервную копию :
- Запустите regedit.exe
- Перейдите в HKEY_CURRENT_USER\Software\Gene6\G6FTPAdmin
- Выберите Меню / Файл / Экспорт и введите имя файла резервной копии.

Чтобы восстановить конфигурацию, дважды щёлкните по .reg-файлу.

Примечание : пароли сервера зашифрованы, вам потребуется снова ввести их в клиенте Удалённого администрирования после восстановления записей реестра.

3 - Администрирование удалённого FTP-сервера

1) Находясь в корне клиента Администратора, щёлкните по "Создать" или используйте кнопки панели инструментов, чтобы создать новый сервер для администрирования.

560x137 (4486 bytes)

2) Fill the new window with the server's information

435x401 (9175 bytes)

3) Новый сервер появится в списке серверов.

623x110 (5182 bytes)

4 - Настройка при наличии маршрутизатора

Вам следует перенаправить запросы, приходящие по протоколу tcp на порт 21 (или на порт, который вы используете) с маршрутизатора на компьютер, на чьём локальном IP запущен G6FTP Server.
Не забудьте открыть порты 21 tcp (разрешить входящие) & 20 tcp (разрешить исходящие) (основной порт & основной порт - 1) в брандмауэре маршрутизатора (если он встроенный), чтобы пользователи могли подсоединиться к серверу.

294x209 (1985 bytes)

Обычно данная процедура разъясняется в документации маршрутизатора, ключевые слова "перенаправление, переадресация портов".

Ссылки на наиболее распространённые маршрутизаторы приведены на странице http://www.g6ftpserver.com/?page=faq.

Пассивный режим :

Если ftp-сервер работает за маршрутизатором, он может использовать только локальные IP (10.0.xxx.yyy, 192.168.0.xxx ...), назначенные вашему компьютеру.
Это вызывает определённые проблемы, когда клиент переключается в пассивный режим (PASV), так как ответ FTP-сервера будет содержать локальный IP в сети; следовательно, ftp-клиент не сможет передавать данные (ни перечень файлов каталога, ни закачка / загрузки, только команды).

Как разрешить данную проблему :
1) В свойствах сервера : Домен / Свойства / Привязка IP, настройте параметр Перенаправить PASV IP, вы можете ввести доменное имя или IP, так чтобы FTP-сервер знал ваш реальный IP.
2) Задайте диапазон портов пассивного режима 50000-50100 в соответствующем поле.
3) На маршрутизаторе (аппаратном или программном) задайте перенаправление диапазона портов 50000-50100 tcp на компьютер, на IP которого запущен ftp сервер. (точно так же, как и в перенаправлении основных портов).

630x461 (17993 bytes)

Основной порт НЕ должен быть включен в диапазон портов пассивного режима. Порт пассивного режима должен быть выбран из портов > 1024 (младшие порты зарезервированы для известных служб).

Теперь ftp-сервер будет использовать внешний IP для пассивного режима, и маршрутизатор будет корректно перенаправлять пассивные соединения благодаря настройке диапазона портов пассивного режима.

Удалённое администрирование :

Вам также придётся перенаправить порт удалённого администрирования с маршрутизатора на IP локального компьютера.
По умолчанию это порт 8021 tcp, он может быть изменён в Администрирование / Свойства / Привязка IP.

5 - Настройка при наличии брандмауэра

Откройте порты 21 (разрешить входящие) & 20 (разрешить исходящие) (основной порт & основной порт - 1), также разрешите прохождения диапазона портов пассивного режима через брандмауэр, см. главу о настройке пассивного режима.

Чтобы разрешить удалённое администрирования, следует открыть порт 8021 (по умолчанию) (разрешить входящие), порт может быть изменён в Администрирование / Свойства / Привязка IP.

Ссылки на наиболее распространённые брандмауэры приведены на страничке http://www.g6ftpserver.com/?page=faq .

6 - Включение SSL для домена

1) Откройте Local machine (или администрируемый удалённый сервер) / FTP Сервер / Сертификаты
2) Щёлкните на значке сертификата на панели инструментов (или щёлкните правой клавишей мыши в правой части окна администратора и выберите Создать сертификат).
3) Введите всю требуемую информацию (см. : FTP Сервер).
4) В домене, который вы создали, перейдите в Свойства / Безопасность / Привязка IP
5) Щёлкните Добавить (+), введите ip для прослушивания (например) : *, 21, "Только стандартные сессии FTP, разрешить явный режим SSL"
6) Щёлкните по Безопасность / SSL, выберите сертификат, созданный в п. 2)


Глава X - Интерфейс учётных записей пользователя

1 - Учётные записи пользователей

Чтобы запустить сервер и сделать его доступным вашим пользователям, следует создать учётные записи, так чтобы пользователи получили доступ к вашим файлам.

В домене : выберите папку Пользователи, нажмите правую клавишу мыши и выберите "Создать", появится новое окно, запрашивающее имя учётной записи. Дважды щёлкните на учётной записи пользователя, которую вы хотите изменить.

Число учётных записей пользователей неограниченно.

630x460 (19832 bytes)

Выбор любой основной категории (Пользователь, Настроить, Безопасность) приведет к отображению страницы с описанием подкатегорий.

2 - Мастер

Мастер поможет вам настроить новую учётную запись, подсказав основные опции, которые необходимо установить.

Шаг первый : выберите имя новой учётной записи и её пароль.
Пароль по умолчанию хранится в виде хэша MD5, пароль регистрозависимый; вы можете использовать генератор паролей, чтобы сформировать случайный пароль из 8 символов (букв и чисел), после создания он будет скопирован в буфер обмена (вы можете вставить его как текст при помощи меню мыши или сочетания Ctrl+V).

448x307 (8453 bytes)

Шаг второй : выберите домашний каталог пользователя, т.е. тот каталог, в котором оказывается пользователь после входа на сервер.
(права доступа по умолчанию таковы: Загрузка, Список файлов, Список каталогов, Подкаталоги).

448x307 (7777 bytes)

Окно, содержащее все настройки, будет показано после нажатия на кнопку Завершить (это можно отключить через Администратор / Сервис / Параметры / Отображать свойства пользователя после создания).

3 - Настройки

Первая группа настроек содержит основные настройки, позволяющие вам включить/отключить учётную запись и выбрать тип пароля.

624x435 (13471 bytes)

Активен : включить/отключить учётную запись.
Только безопасные подключения (SSL) : разрешить только шифрованные соединения (SSL) для данной учётной записи, стандартные подключения будут отклоняться.
Истекает : учётная запись будет работать до указанной даты.
Группы : включив пользователя в состав группы, вы обеспечиваете большую гибкость в настройке учётной записи.

Тип пароля : Принимать адрес e-mail, Авторизовать по базе данных пользователей NT, OTP S/KEY MD5, Стандартный пароль, Стандартный пароль, хранящийся в виде MD5.
Пароль : the password to use with the login name.

В зависимости от типа пароля, пароль будет приниматься и храниться по-разному :
- Принимать адрес e-mail : принимаемый пароль должен быть в виде : user@domain.com
- Авторизовать по базе данных пользователей NT : пароль будет проверяться по базе данных пользователей NT для входа на сервер.
- OTP S/KEY MD5 : Единовременный пароль. Пароль, прередоставляемый пользователем, должен вычисляться по начальному числу, возвращаемому сервером после получения логина. Таким образом, при каждом новом подключении пересылается новый пароль. Требует наличия поддерживающего данную функцию FTP-клиента (см. http://www.ietf.org/rfc/rfc1938.txt).
- Стандартный пароль : пароль хранится в незашифрованном виде на стороне сервера. Нет специальных требований для пользователя.
- Стандартный пароль, хранящийся в виде MD5 : то же, что и Стандартный пароль, но вместо простого текста хранится хэш MD5.

4 - Права доступа

Наиболее важная часть настройки учётной записи : файлы и папки, к которым пользователь сможет получить доступ, которые сможет просматривать и передавать.

См. : Виртуальная файловая система

5 - Разное

На данной странице вы можете настроить различные опции - от сообщений сервера до наибольшего числа разрешённых подключений.

624x435 (14188 bytes)

Разное :

Может менять пароль : пользователь может менять свой пароль при помощи команды "SITE PSWD oldpass newpass".
Прятать скрытые файлы : файлы и каталоги с атрибутом "скрытый" не будут отображаться в списке файлов сервера.
Вести журнал : если включено, то активность данной учётной записи будет отображена в журнале сервера.
Таймаут по простою : пользователи, не осуществляющие никаких действий за этот период времени, будут отключены.
Таймаут сессии : если включено, пользователь будёт отключаться по прошествии заданного периода времени.

Соединение :

Макс. клиентов : позволить только N пользователям входить на сервер с данной учётной записи, по умолчанию неограниченно.
Игнорировать настройки домена : если в домене установлено ограничение макс. числа пользователей, эта опция позволит пользователю войти на сервер, даже если достигнуто макс. число пользователей на сервере.

Макс.соед. с одного IP : разрешить только N соединений с одного IP, по умолчанию неограниченно.
Игнорировать настройки домена : если включено, соответствующие настройки домена будут игнорироваться.

Файлы с сообщениями :

Смена каталога : сообщение отсылается каждый раз при смене пользователем каталога (можно задать только имя файла, без пути, чтобы использовать файл из текущего каталога)
Файл с приветствием : отсылается после общего приветствия домена.

6 - Дополнительно

Данная страничка позволяет вам настроить списки, ограничить размер файлов, установить правила безопасности при передачах третьей стороне.

624x435 (13185 bytes)

Дополнительно :

Отключённые команды : если вы хотите отключить некоторые команды типа XCRC, XMD5 для анонимной учётной записи, введите их здесь (разделяйте команды запятыми).
(см. главу : Документы, в которой приведён список поддерживаемых команд FTP)
Параметры списка исключаемых : позволяет ограничить параметры LIST & NLST. Поддерживаемые параметры : a, A, B, c, i, k, p, Q, r, s, S, t, T, u, U, X (ниже приведено полное описание).

424x468 (12296 bytes)

Макс.размер файла для закачки на сервер : файлы большего размера не могут храниться на сервере (закачка будет отклонена).

FXP, сервер-сервер :

Разрешить входящие передачи типа сервер-сервер : разрешить подключение к другому серверу для закачки данных.
Разрешить исходящие передачи типа сервер-сервер : разрешить подключение к другому серверу для загрузки данных.

NT :

Выдавать себя за другого : клиенты могут выдавать себя за пользователей Windows, ограничения зависят от типа учётной записи windows.

7 - Заблокированные файлы

﻿ Заблокированные файлы - это файлы, которые не могут храниться на сервере.
Вы можете задать маску файлов/пути (поддерживаются ?, *) : *.jpg, c:\path\images_200?\

Примечания :
- правила не применяются к загрузкам, только к закачке на сервер
- правила также применяются при переименовании файла

624x435 (11235 bytes)

8 - Доступные файлы

Доступные файлы - это файлы, которые могут быть загружены вне зависимости от пропорции (если вы не используете Пропорции, оставьте поле пустым).
Вы можете задать маски файлов/путей (поддерживаются ?, *) : *.jpg, c:\path\images_200?\

624x435 (11025 bytes)

9 - Квота, пропорции

Пропорции предназначены для того, чтобы разрешить передачу при получении, это наследие BBS.

Например, если вы хотите, чтобы пользователь мог загрузить 1 байт за каждый закачанный на сервер байт, установите соотношение 1/1; 1 байт закачки для загрузки 2 байтов соответствует пропорции 1/2. Если закачан файл размером 100 байт, а пропорция 1/2, пользователь сможет загрузить 200 байт; если пропорция 2/1, то только 50 байт будет доступно для загрузки пользователю.

624x435 (12753 bytes)

Закачка : новый кредит = текущий кредит + пропорция загрузки / пропорция закачки * размер файла
Загрузка : новый кредит = текущий кредит - размер файла

Подсчитывать байты для каждого соединения / Подсчитывать файлы для каждого соединения : этот кредит работает только во время соединения; кредит разный для всех пользователей, подсоединённых с данной учётной записи.
Подсчитывать байты для всех соединений / Подсчитывать файлы для всех соединений : кредит сохраняется после отключения, поэтому при следующем подключении ваш кредит будет равен тому, который был у вас при отключении.

Квота : данная настройка позволяет вам установить наибольшее значение дискового пространства, которое пользователь может занять на вашем сервере. Как и Пропорции, Квоты вычисляются при закачке на сервер (для метода REST , и т.д.). Пользователь не может закачивать данные на сервер, если он превысил квоту => он должен загрузить несколько файлов. Если квота пользователя нулевая и он удаляет файл, его квота остаётся нулевой.
Рассчитывать квоту при входе на сервер : если включено, то сервер будет обновлять текущее значение квоты путём просмотра всех каталогов и подсчёта используемый байтов (это может занять некоторое время, в зависимости от числа файлов и сложности системы каталогов).

10 - Скорость передачи

По мере роста числа быстрых подключений может создаться ситуация, когда несколько пользователей занимаю весь ваш канал.
Чтобы управлять настройками скорости, можно задать Макс. скорость и Наименьшую скорость подключений.

624x435 (12946 bytes)

Макс. скорость для каждого соединения : для каждого подключения с данной учётной записи будет установлен одинаковый передел (у всех пользователей будет одинаковый скоростной предел).
Макс. скорость для всей учётной записи : ограничение будет применяться ко всем пользователям, соединённым с данной учётной записи (если с данной учётной записи подключено n пользователей, то скорость = ((Макс. скорость) / n). Это прекрасная возможность ограничить скорость анонимных подключений.
Наименьшая скорость : Если скорость подключения пользователя ниже Наименьшей скорости, он будет отключён и, возможно, заблокирован на определённое время.

Можно комбинировать настройки: установка Макс. скорости для каждого соединения и Макс. скорости для всей учётной записи приведёт вначале к ограничению скорости текущего подключения пользователя, а затем к общему ограничению для всех соединений пользователя с данной учётной записи.

Примеры :

Проблема : Вы хотите ограничить использование полосы пропускания для анонимной учётной записи, которая может быть использована многими пользователями, значением 25 KБ/с
Решение : Установите Макс. скорость для всей учётной записи 25 KB/s, оставьте другие настройки по умолчанию.

Проблема : Один из ваших пользователей использует менеджер загрузок, который устанавливает множество подключений для загрузки с одной учётной записи.
Решение : Установите требуемое значение Макс. скорости для всей учётной записи, оставьте другие настройки по умолчанию, менеджер загрузок будет ограничен.

Проблема : У вас есть анонимная учётная запись, вы хотите, чтобы все использовали соответствующие значения полосы пропускания.
Решение : Установите Макс. скорость для каждого соединения 25 КБ/с, KB/s, оставьте другие настройки по умолчанию. (дополнительно настройте Макс. количество соединений с одного IP, установите значение не менее 2).

Проблема : Вы ограничили сервер десятью подключениями, но у одного из пользователей проблемы с сетью, низкая скорость передачи, он долго занимает одно соединение.
Решение : Установите Наименьшую скорость 5 КБ/с, оставьте другие настройки по умолчанию. Если скорость подключения пользователя ниже Наименьшей скорости, он будет отключён и, возможно, заблокирован на определённое время.

11 - Предел передачи

Здесь вы можете настроить что-то типа квоты передачи в день. Можно задать предел загрузки или закачки, применить ежедневно, еженедельно или ежемесяно.

624x435 (11563 bytes)

﻿ Текущее значение : всего МБайт передано.
Макс : максимумальное число МБайт, которое может быть передано.

Сброс (ежедневно, еженедельно, ежемесячно) : ограничения будут сбрасываться каждый выбранный период.

При помощи данной опции вы в качестве хостинговой компании можете назначить максимум трафика в месяц пользователю.

12 - Время доступа в день

Данная страница позволяет вам ограничить время доступа учётной записи в течение дня.
Вы можете задать ограничения глобально или отдельно для каждого дня.

624x435 (14877 bytes)

Включено : включить или отключить ограничения.
Всегда одно расписание : задать ограничения глобально или отдельно для каждого дня.

13 - Примечания по учёнтной записи

Оставьте некоторую информацию, такую как Имя, Адрес, Город, адрес E-mail и т.п.

624x435 (13070 bytes)

Доступ к этой информации можно получить при помощи тегов - для использования в скриптах или событиях.

14 - Статистика

Отображение статистики учётной записи.

624x435 (12637 bytes)

﻿ Подключения : число соединений.

Логины : количество пользователей, вошедших с данным логином.
Неудачные попытки входа : число неудачных подключений.

В данный момент подключено : число пользователей, подключённых к серверу в настоящее время.

Последнее подключение : дата последнего подключения.
Последнее имя пользователя : последний использованный логин (для псевдонимов).
Последний IP : последний известный IP.

Неудачных/прерванных закачек : число неудачных закачек.
Файлов закачано на сервер : число закачанных файлов.
Закачано : количество закачанной информации (байт).

Неудачных/прерванных загрузок : число неудачных загрузок.
Файлов загружено : число загруженных файлов.
Загружено : количество загруженной информации (байт).

Вы можете скопировать текущую статистику в буфер обмена или сбросить её при помощи кнопок панели инструментов.

15 - Скрипты

Выбор запускаемых скриптов для данной учётной записи.

624x435 (10871 bytes)

Для получения дальнейшей информации обратитесь к главе : Скрипты

16 - Команды SITE

624x435 (11795 bytes)

﻿ Щёлкните, чтобы задать новую команду SITE

Доступные теги командной строки :

$_ : число параметров.
$0 : параметры не анализируются.
$1 : параметр 1
...
$n : параметр n

Вы также можете использовать общие теги : Теги

Если вы хотите, чтобы вывод приложения был доступен пользователю, установите флажок "перенаправить вывод приложения клиенту". Сервер предполагает, что команда возвращает форматированный вывод (с кодом ошибки).
Также полезно задать таймаут, если приложение слишком долго работает.

17 - Доступ по IP

﻿

Задание ограничений, таких как доступ по IP, позволяет вам запретить доступ или разрешить доступ только пользователям, которым вы доверяете.
Права могут назначаться как по IP, так и по имени узла.

Например :

+*.gene6.net (единственное правило) позволяет любому пользователю с доменным именем gene6.net подключиться к серверу; всем, кто не соответствует правилу, доступ будет запрещён.

-*.gene6.net (единственное правило) позволяет подсоединяться всем, кроме пользователей домена gene6.net.

Вы также можете использовать символы *,?,[x-y] в масках : [192-193].16?.[0-10].*, *.net?.nerim.fr - это допустимые маски.

Имена, задаваемые в списке доступа по IP, не определяются во время работы. Сервер берёт IP клиента, обращает DNS и сравнивает со списком доступа к IP/домену. Домен dyndns работает только в направлении от Имени к IP, по IP нельзя определить доменное имя dyndns, обычно только доменное имя провайдера, например, 12-20-14-25.yourisp.com.

(Не забудьте, что списки доступа по IP уровня сервера и домена имеют приоритет над пользовательским списком)

18 - Категория (класс) пользователей

Категория пользователей - это специальная учётная запись, чьи настройки применяются к членам класса, что позволяет администратору установить основные общие настройки всем членам класса. В отличие от группы, пользователь может быть членом только одного класса и не более, это позволяет использовать несколько вариантов настроек.

624x435 (12981 bytes)

Для категория пользователей доступны практически все настройкти пользователя (статистика не будет использоваться, поэтому она не будет отображаться при редактировании её свойств), категория используется как родительский класс для пользователей.

Можно присеодинять пользователей к определённой катгории. Пользователи, присоединённые к катгории, будут использовать большинство настроек родительского класса и будут иметь меньше собственных настраиваемых параметров (например, при настройке квоты/пропорции, вы будете иметь возможность редактировать кредит пропорции и текущую квоту).

Если вы отключите категорию, то все пользователи, присоединённые к данной категории, такж будут отключены. Если категория включена, то пользователей можно отключать поодиночке.

Если вы зададите пароль в категории пользователей, то все пользователи, присоединённые к категории, будут иметь те же настройки пароля. Если пароль не задан, вы можете задать пароли на уровне пользователей (то же для истечения срока действия).

Вот список свойств, которые невозможно изменить для пользователей, присоединённых к категории (настройки будут наследоваться из настроек категории) :
- Все параметры в п. Разное, Дополнительно, Скорость передачи, Время доступа в день, Скрипты
- Группы будут теми же, что и в категории
- при настройке квоты/пропорции, вы будете иметь возможность редактировать кредит пропорции и текущую квоту, если квота/пропорции включены на уровне категории.

Клиенты не могут входить на сервер в качестве категории.

Создание класса сходно с созданием учётной записи пользователя (см. выше). Чтобы присоединить пользователя к категории, выберите его, щёлкните правой клавишей мыши, в контекстном меню выберите "Присоединить к" и категорию.


Глава XII - Виртуальная файловая система

1 - Как это работает

Виртуальная файловая система (файловая система далее обозначается ФС) позволяет вам устанавливать соответствие между виртуальными и реальными каталогами.
Это позволяет вам предоставлять пользователям общий доступ к вашим файлам и папкам при помощи учётных записей

432x353 (6834 bytes)

2 - Доступные ресурсы

Локальная ФС : c:\.. (ФС windows)
Объединить ФС : merge:// (объединение каталогов)
ФС памяти : Ramdisk:// (виртуальный диск)
Удалённые ресурсы по FTP : ftp://login:password@ip/ (ресурсы FTP сервера)
Пустой : Empty:// (создаёт пустой виртуальный каталог, полезно для монтирования различных каталогов в корневой каталог)

Вы также можете использовать UNC (\\computer\), чтобы подмонтировать каталог, в учётной записи пользователя.
(Примечание : Учётная запись локальной ФС NT (учётная запись службы по умолчанию) не имеет доступа к сетвеым или закартированным дискам, поэтому вам следует создать нового пользователя, у которого будет доступ к сети в свойствах служб.)

Замечание о "merge://" :
- можно объединять любое количество каталогов.
- если путь содержит запятую, закомментируйте её : "c:\ftproot\files, datas\"
- повторяющиеся файлы и подкаталоги будут отражены в списке лишь однажды.
- повторяющиеся подкаталоги также будут объединены.
- права доступа применяются ко всем объединённым каталогам.
- закачка/создание каталогов всегда будет производиться в первый каталог/первом каталоге из списка объединения.
- при удалении сервер будет просматривать каждый каталог, пока не найдёт файлы; если есть повторные файлы, файл будет удалён лишь однажды, это означает, что он может по-прежнему содержаться в списке (в этом случае в список он попадает из другого каталога).

3 - Права доступа

Уровень файла :
- Загрузка : пользователь может читать файлы с сервера.
- Закачка : пользователь может записывать файлы на сервер.
- Удаление : пользователь может удалять файлы с сервера.
- Дополнение : пользователь может возобновлять закачку файла.

Уровень каталога :
- Список файлов: пользователь может просматривать список файлов.
- Список каталогов : пользователь может просматривать список каталогов.
- Создать : пользователь может создавать каталоги на сервере.
- Удалить : пользователь может удалять каталоги с сервера.
- Подкаталоги : пользователь может перейти в подкаталог текущего каталога.
- Скрыть : пользователь не увидит каталога.
- Безопасный : для входа в каталог пользователю придётся установить шифрованное (ssl) соединение.
- Запретить : пользователю запрещён доступ к данному каталогу.

- Все : установить все флажки.

Примеры

1) Вы хотите создать анонимную учётную запись на сервере.

В правах доступа вы указываете :

Виртуальный путь : /
Реальный путь : c:\ftproot\anonymous\
Права доступа : Загрузка, Список файлов, Список каталогов, Подкаталоги.

Более продвинутое решение :

Виртуальный путь : /
Реальный путь : empty://
Права доступа : Список файлов, Список каталогов, Подкаталоги (empty:// содержит только другие соответствия, поэтому запись запрещена)

И ещё одно :

Виртуальный путь : /public
Реальный путь : c:\ftproot\anonymous\
Права доступа : Загрузка, Список файлов, Список каталогов, Подкаталоги.

2) как предоставить всем пользователям определённый каталог для закачки и общие права доступа для загрузки.

a) Создать корневой каталог

Виртуальный путь : /
Реальный путь : empty://
Права доступа : Загрузка, Список файлов, Список каталогов, Подкаталоги

b) Задать общий каталог для загрузки

Виртуальный путь : /download
Реальный путь : c:\ftp\download
Права доступа : Загрузка, Список файлов, Список каталогов, Подкаталоги

c) Задать определённый каталог для закачек

Виртуальный путь : /upload
Реальный путь : c:\ftp\upload\$USR_ACCOUNT\
Права доступа : Загрузка, Закачка, Удаление, Список файлов, Список каталогов, Создать, Удалить, Подкаталоги
(не забудьте создать каталог c:\ftp\upload\$USR_ACCOUNT\, во время работы $USR_ACCOUNT заменяется на имя учётной записи).

d) (опционально) Сделать каталог закачки читаемым для других.

Виртуальный путь : /download/others
Реальный путь : c:\ftp\upload\
Права доступа : Загрузка, Список файлов, Список каталогов, Подкаталоги

3) Объединение нескольких каталогов в один (полезно, когда кончается место на диске)

Виртуальный путь : /
Реальный путь : merge://"c:\images\buildings\","d:\images\houses\","e:\images\flowers\"
Права доступа : Загрузка, Список файлов, Список каталогов, Подкаталоги

4 - Дополнительно

Теги

При задании прав доступа вы также можете использовать теги (см. : Теги), чтобы динамически смонтировать каталог в зависимости от имени учётной записи пользователя, например (теги могут использоваться как в виртуальных, так и в реальных каталогах).

Вы можете создать : "c:\ftp\$DOM_NAME\$USR_ACCOUNT\", смонтированный в "/" с соответствующими правами доступа.
При вашем входе сервер будет искать ваш корневой каталог в c:\ftp\ftp.gene6.com\anonymous\ (если вы подключаетесь анонимно к домену "ftp.gene6.com")

Возможны варианты, например : "c:\ftp\$USR_GROUP\" , монтируемый в "/$USR_GROUP", чтобы предоставить общий доступ к файлам членам группы.

Специальные соответствия

Перемещение файлов в ftp-каталоге может привести к неработоспособности старых прямых ссылок, пользователи не смогут загружать файлы, пока ссылки не будут обновлены.
Чтобы решить эту проблему, вы можете создать соответствия файлов (примерно так же, как и перенаправление в http, но прозрачно).

Рассмотрим пример :

- вы распространяете установочный файл, в имени которого содержится номер версии "setup_v1.0.0.exe", расположенный в "c:\ftproot\www.yoursite.com\files\"
- выпущена новая версия, тепрь имя файла "setup_v2.0.0.exe", все сайты, ссылающиеся на ваши файлы, будут вынуждены обновить свои ссылки (это может занять некоторое время ...)

Решение состоит в том, чтобы создать новое правило доступа :

Виртуальный путь : /files/setup_v1.0.0.exe
Реальный путь : c:\ftproot\www.yoursite.com\files\setup_v2.0.0.exe
Права доступа : такие же, как и в исходном каталоге.

Так, когда пользователь запросит "setup_v1.0.0.exe", то, поскольку файл больше не существует, пользователю передаётся содержимое "setup_v2.0.0.exe"
(ограничение : файл по-прежнему называется "setup_v1.0.0.exe" у пользователя, здесь отличие от http, где вы можете сделать перенаправление на новое имя).

Это также будет работать при перемещении файлов в другой каталог :

Виртуальный путь : /old_location/setup.exe
Реальный путь : c:\ftproot\www.yoursite.com\new_location\setup.exe
Права доступа : такие же, как и в исходном каталоге.

Файл по-прежнему будет доступен и будет присутствовать в виртуальном списке в /old_location/ , но физически он будет находиться только в \new_location\